0

I have an old raspberry pi 2011.12. It has installed an up to date raspbian (headless).

It is connected to my local wifi network and internet. SSH is enabled. The following commands work fine on the raspberry:

ping google.com
ping loclahost
ssh localhost

enter image description here

However when I ping to raspberry from other devices (tried few of them) or ssh - it does not work. I am trying to access using ip address 192.168.1.167. The ip address I determined correctly (it is different for wifi and ether connection). It is working fine when I connect the raspberry to my router via cable.

P.S. It may be the issue not only with wifi connection but it seems with ethernet I have the same issue. Sometimes this issue disappears but in most case I cannot ping the board from outside.

6
  • Unless the openssh daemon has been configured to bind against a specific IP address it should bidn to all available network addresses. Whats your network configuration for the wifi on the PI? Feb 1 at 9:51
  • 1
    Added my iwconfig output
    – Solvek
    Feb 1 at 9:58
  • what is the IP address of the device sending the ping
    – Bravo
    Feb 1 at 12:43
  • Pinging from 192.168.1.169 but also pinged from phone (in the same wifi network)
    – Solvek
    Feb 1 at 15:30
  • 1
    Does you home router block local connections. Check the control panel 192.168.1.1 or 192.168.1.254 settings for "WiFi Isolation" or "wireless isolation".
    – Dougie
    Feb 1 at 17:11

1 Answer 1

-1

Your ifconfig report says the WLAN IP address is 192.168.1.167, but you say you are trying to ping the address 192.168.167. That is the problem.

[Update] If you were actually trying to ping 192.168.1.167, then check the IP address of the system initiating the ping; is it also in the 192.168.1 subnet? If not, then check the settings in the device that should be doing the routing between the two subnets.

2
  • Typo... I was pinging 192.168.1.167
    – Solvek
    Feb 1 at 11:39
  • Thanks for the response. I checked the IP address. The information is in my screenshot in the question.
    – Solvek
    Feb 1 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.