When I try to install antimicrox-3.2.1-x86_64.deb and confirming I want to install it I get an error saying:

Failed to install file. A package could not be found that allows the action to complete. More information is available in the detailed report.

I am relatively new to Debian and Linux as a whole so I don't know where to find the detailed report. Is there an explanation to this error?

Here is where I downloaded the file: https://github.com/AntiMicroX/antimicrox/releases

  • 2
    because raspberry pi isn't a x86_64 architecture - it's armhf architecture you're looking for - or arm64 if you're running 64 bit raspberry pi OS - which I doubt
    – Bravo
    Feb 2, 2022 at 2:10
  • 1
    though, the deb package you want to install doesn't seem to come in arm flavour - you'll have to compile it from source
    – Bravo
    Feb 2, 2022 at 2:17
  • though - if you look at the github issues, you'll find lots of help github.com/AntiMicroX/antimicrox/… and you can even use debian repository to install it without needing to compile - it's in one of those issues linked before - github.com/AntiMicroX/antimicrox/issues/121
    – Bravo
    Feb 2, 2022 at 2:22
  • 2
    not sure which thing worked - you could write an answer to your own question detailing exactly what you did :p
    – Bravo
    Feb 2, 2022 at 8:27

1 Answer 1


I was installing the wrong version. After taking a download from this page, it worked perfectly.

  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Feb 3, 2022 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.