0

I have an RPi running XBMC attached to a Samsung TV. Furthermore, I have a large HDD attached to the RPi by USB and an Edimax WLAN adapter in the other USB port. What I want to do is to be able to access (read & write) the files on the HDD using several Windows 7 computers in the same network. Some of these computers are attached to the network via WLAN and others via Ethernet cable. The RPi is currently attached via WLAN (but could if necessary be attached via Ethernet cable). Only a very simple setup is needed (only one username etc.).

What would be the best way to do this. Specifically, what is the best (but still convenient on the Windows side) technology to do this (Samba, FTP, SCP, ...?). Does the filesystem on the HDD matter (currently it is NTFS but it could easily be reformatted)? Does it make sense to connect the PRi via ethernet? What is the best OS on the RPi (currently I run XBian)?

1

I have the same setup, I just enabled the upnp in the XBMC (I did it on both openELEC and xbian). For me it is as easy as enabling it in the configuration panel (no command line needed)

If using XBMC v11 "Eden": Settings → Network → Services If using XBMC v12 "Frodo": Settings → Services → UPnP

From the windows point of view nothing needs to be installed.

This page should help: Share libraries using UPnP

look for upnp or samba in you settings (again it needs no extra packages on the windows machine)

As for the best OS, IMHO, if you ONLY need XBMC, openELEC (with slight overclock) if you need XBMC and something else, xBian (that introduces slight overclock by default) (Booth allow easy file sharing via upnp/smb)

  • 1
    The UPnP protocol, as default, does not implement any authentication – rob Feb 10 '14 at 14:28
  • Thanks! Hoewever, I assumed that via Upnp I can only share my libraries (meaning: access the movie files registered in a library in XBMC). Can I also access (& write) in all directories of the HDD attached via USB to the RPi? – ares_games Feb 10 '14 at 18:34
  • Alright, I can access the directories via UPnP but I cannot write or delete files. Windows tells me I do not have permission to do this. How can I fix this? – ares_games Feb 11 '14 at 4:06
  • 1
    hum .. one possibility is to change the files to 777 chmod -R 777 . and change the default value for future files to the same. You can also try samba instead. I can check my setup this evening and tell u what I exactly did – javirs Feb 11 '14 at 8:07
  • Yes, this could work. However, I currently cannot connect to the RPi. I got the IP address but both Putty and WinScp fail to connect (I tried root and xbian for username). – ares_games Feb 11 '14 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.