1

i experienced some serious problems with my Raspberry Pi 4 regarding my USB 3.0 ports. I was using the raspberry as a server (torrents, ftps, http etc...). To store the data i opted for a 1Tb usb hdd i had laying around, I plugged it in and it worked absolutely fine for months, one day i noticed that i wasn't able to access my ftps cliend so i connected to ssh to check the problem. I noticed that the hdd was somehow disconnected (not recognized, i tried using lsusb to check but it was undetected). I started searching through logs when i started to see some particular lines in dmesg

device descriptor read/64, error -110

device descriptor read/64, error -71

I tried everything, from buying a powered usb cable to add config to modprobe to make usbcore use the old linux usb schema, i formatted the sd and put a new copy of raspberry pi os. I tested with other usb devices, the hdd works flawlessly with other computers. I also tried to connect a small 8 Gb usb stick to the raspberry to see if the problem was of the hdd but the raspberry didn't recognize the stick too. Basically when i connect the hdd to the raspberry the led of the hdd powers up for 3 to 10 seconds then it goes dark again. The only way to make it work is to use the USB 2.0 ports, but it's a temporary arrangement since i want to install a usb sdd to the raspberry instead of the sd.

I hope to resolve this problem soon, so thanks in advance for any help.

4
  • What OS are you running on your RPi 4?
    – Sanders
    Feb 6, 2022 at 9:26
  • @Sanders: note the OP's statement, "i formatted the sd and put a new copy of raspberry pi os."
    – Seamus
    Feb 7, 2022 at 0:00
  • A little more information might help. Run lsusb -t, & add the output to your question. You might also run sudo lsusb -v & peruse the output (probably not useful to post all output). IIRC, eth0 and the USB3 share some hardware, so it might be useful to verify whether or not your RPi4 can connect to your network via ethernet cable.
    – Seamus
    Feb 7, 2022 at 0:48
  • I overlooked what OS you're running, I can be blind. Anything in dmesg | grep usb by chance as well?
    – Sanders
    Feb 7, 2022 at 1:24

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.