0

On the newest PI OS bullseye (not beta!) I installed the xrdp and added user xrdp to the ssl-cert group. When I open the RDP session on w10 PC and try to log to PI4 I get an error saying:

connecting to sesman ip 127.0.0.1 port 3350 
sesman connect ok sending
login info to session manager, please wait... 
login succesful for display 11 
started connecting connection problem, giving up 
some problem

When I checked the status of the xrdp service it shows that the service is started and running, but it shows some errors:

Feb 06 12:36:10 pi4-8 xrdp[191346]: [INFO ] Socket 12: AF_INET6 connection received from ::ffff:82.208.181.53 port 52965
Feb 06 12:36:10 pi4-8 xrdp[394313]: [INFO ] Using default X.509 certificate: /etc/xrdp/cert.pem
Feb 06 12:36:10 pi4-8 xrdp[394313]: [INFO ] Using default X.509 key file: /etc/xrdp/key.pem
Feb 06 12:36:10 pi4-8 xrdp[394313]: [ERROR] SSL_accept: I/O error
Feb 06 12:36:10 pi4-8 xrdp[394313]: [ERROR] trans_set_tls_mode: ssl_tls_accept failed
Feb 06 12:36:10 pi4-8 xrdp[394313]: [ERROR] xrdp_sec_incoming: trans_set_tls_mode failed
Feb 06 12:36:10 pi4-8 xrdp[394313]: [ERROR] xrdp_rdp_incoming: xrdp_sec_incoming failed
Feb 06 12:36:10 pi4-8 xrdp[394313]: [ERROR] xrdp_process_main_loop: libxrdp_process_incoming failed
Feb 06 12:36:10 pi4-8 xrdp[394313]: [ERROR] xrdp_iso_send: trans_write_copy_s failed
Feb 06 12:36:10 pi4-8 xrdp[394313]: [ERROR] Sending [ITU T.125] DisconnectProviderUltimatum failed

There seems to be an issue with encryption (?) so I checked out the certificates and their privileges (through symlinks too) but they seem to be ok. Due to my lack of knowledge, I am not able to troubleshoot any deeper than that.

BTW: a few weeks ago I tried the same thing on 32-bit bullseye installation with same result , but I haven't followed up because I decided to wait for the ARM64 release

2 Answers 2

0

This helped me

sudo nano /etc/X11/xrdp/xorg.conf

Find:

Option "DRMDevice" "/dev/dri/renderD128"

Change to:

#Option "DRMDevice" "/dev/dri/renderD128"
Option "DRMDevice" ""

Save and exit

sudo reboot

0

lsb_release -a

No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 11 (bullseye)
Release: 11
Codename: bullseye

#####################################
User pi can not login into rdesktop !
#####################################

1)
make shure rdesktop is installed ...
sudo apt update
sudo apt install rdesktop

2)
create an other user then pi
example:

useradd newusername
pwd newusername
enter passsword - confirm password ...
sudo usermod -a -G newusername

sudo mkdir /home/newusername
cd /home
sudo chown newusername:newusername newusername
cd newusername
sudo mkdir Desktop
chown newusername:newusername Desktop

3)
after login get rid of annoying message:
"authentication-required-to-refresh-system-repositories"

sudo bash
cd /etc/polkit-1/localauthority/50-local.d
nano 46-allow-update-repo.pkla

Insert into "6-allow-update-repo.pkla" :
-SNIP->
[Allow Package Management all Users]
Identity=unix-user:
Action=org.freedesktop.packagekit.system-sources-refresh
ResultAny=yes
ResultInactive=yes
ResultActive=yes
<-SNIP-

reboot and then RDP-Login with newusername !
done ...

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 30 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.