I'm running GPSD 3.23.1 built from source but this also occurred on GPSD 3.22-4 from the debian/raspbian repositories.

When I launch any gpsd client, gpsd sends the first fix it managed to acquire, and then sends nothing else. Two fixes for this are running ubxtool -p RESET or unplugging, then replugging the gps mouse, however neither of these persist past a restart of the daemon.

The GPS mouse is not broken as it works just fine on other devices running gpsd and on gpsmon.

The only other case of this that I could find online is on this reddit thread.

1 Answer 1


I had the exact same problem and updating gpsd to version 3.25 solved the issue. I followed these instructions that I found in the comments of the Reddit thread you pointed to.


sudo apt install -y scons \
  libncurses-dev python-dev pps-tools git-core asciidoctor python3-matplotlib\
  build-essential manpages-dev pkg-config python3-distutils

wget http://download.savannah.gnu.org/releases/gpsd/gpsd-3.25.tar.gz
tar -xzf gpsd-3.25.tar.gz
cd gpsd-3.25/

sudo scons
sudo scons install
sudo reboot

Note: This won't setup the system's service as it would by installing gpsd with sudo apt install gpsd gpsd-clients, so you have to start it manually using: sudo gpsd --nowait --badtime --speed 9600 /dev/ttyACM0 (adjust the parameters for your setup).

  • I'll mark this answer as accepted once I'm able to test this. Thanks for the system service extra info, I missed that in my earlier research.
    – OskarZyg
    Commented Mar 13, 2023 at 19:44
  • This worked for me, however for some reason the GPSD service was not running the new version. So make sure that /usr/sbin/gpsd is the proper binary. In my case I had to copy the 3.25 one from /usr/local/sbin. My best guess is that it wasn't updated because the service was running when it should have been replaced? Either way, replacing it makes everything work.
    – ashley
    Commented Mar 29, 2023 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.