0

My problem is that I have a fresh installation of XBian and XBMC but I cannot connect to the RPi via SSH from a Windows 7 PC in the same network. The router recognizes the RPi (I got the IP) but any connection is refused. Both, computer and RPi are connected via WLAN. I tried root and xbian for usernames. I tried Putty and WinSCP. The UPnP sharing of libraries works nicely (but is readonly).

  • 1
    Are you getting prompted for a user/pass or just connection refused? Is port 22 open in your router? What is the output of service ssh status on the pi? – 에이바 Feb 11 '14 at 18:37
  • The ssh service is started on the pi (status obtained with XBMC). I just get connection refused / closed (no prompts for user/pass). Other ssh servers (outside the LAN) are accessible so I assume port 22 is open in my router. – ares_games Feb 11 '14 at 18:57
1

I never used XBIAN, so i don't know if the ssh server is enabled by default.

From what I've read, the username xbian and the password raspberry should work, unless your keyboard setting is off (QWERTZ vs QWERTY).

Did you try raspberrz as the password?

EDIT

Try to ssh to the ip of the server using the -v option, which gives a more verbose output. You can use this option up to three times (-vvv).

Maybe you can post the output of

ssh -v pi@xxx.xxx.xxx.xxx

and somebody else has a good idea then.

  • Unfortunately, I do not get to the point where the password could fail. Connection attempts fail / are answered by "Connection closed". – ares_games Feb 11 '14 at 18:55
  • 1
    The problem was solved by switching to OpenELEC where SSH worked out of the box. – ares_games Feb 12 '14 at 23:53
1

I've found that the first attempt to connect fails. If I immediately attempt to connect after the failure, I get a login prompt and can login.

0

I am new to Raspberry PI and I met the same issue on first install - connection was refused before having the chance to enter the password.

In fact, I used the windows install package to format and copy the files to the SD card. I though the OS was installed on it. When connection the PI to the HDMI cable, it is obvious that another step is required to complete xbian installation (can be done with a USB mouse - no keyboard needed). Once completed, I could ssh the PI properly. Hope it helps

0

I had a similar problem with Raspbian, also after a fresh install.

Have you checked the ssh-daemons logs? It should state why a connection attempt fails.

My error was:

Aug 19 11:52:44 retropie sshd[9707]: error: key_load_public: invalid format
Aug 19 11:52:44 retropie sshd[9707]: error: Could not load host key: /etc/ssh/ssh_host_rsa_key

If you have a similar error, look at this: SSH not working over WLAN (ssh enabled, ping works, tcpping on port 22 works)

  • Thanks for your answer but we are looking for comprehensive answers that provide some explanation and context. Very short answers cannot do this, so please edit your answer to explain why it is right. Additionally, we prefer answers to be self contained where possible. Links tend to rot so answers which rely on a link can be rendered useless if the linked to content disappears. If you add more context from the link, it is more likely that people will find your answer useful. – Greenonline Aug 22 '18 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.