For quite a long time now my Raspberry PI 4 has been loosing connectivity every few weeks. However the last 2 weeks or so my Raspberry PI has been losing connectivity almost daily. I'm running quite a standard setup on it with docker, portainer and some other docker containers. Whenever this happens I simply power cycle the device and everything works again.

I got a bit fed up with this so I started doing some investigation. I ran the ip addr command and saw this: enter image description here

As can be seen here for some reason the IPv4 address is missing. I tried unplugging the network cable and plugging it back in again but this didn't fix the issue. I then saw that it did still have an IPv6 address, so I tried to SSH to the PI using that address which unexpectedly worked perfectly.

I then tried to refresh the IP address by running sudo dhclient -r and sudo dhclient. This fixed the problem.

I have no idea why this issue happens though, so I'm looking for some help :).

Edit: As requested, here's the information on the version of Linux running on my PI: enter image description here

uname -m: aarch64

Edit2: I've also added a screenshot of the service --status-all command: enter image description here

Edit3: Here's the output of the systemctl status dhcpcd.service command: enter image description here

It seems like the error route socket overflowed - learning interface state is the problem here. What could be the cause for this?

Edit4: I've now tried this workaround, hopefully this fixes the issue: https://github.com/raspberrypi/linux/issues/4092#issuecomment-774512217

  • As you haven't said what OS or how it is configured no one can say. Raspberry Pi OS doesn't use dhclient although it will renew leases. Should not be necessary with a normal dhcpcd setup.
    – Milliways
    Feb 25, 2022 at 0:04
  • I've added information on what version of Raspberry Pi OS it's running. Could it be that something is configured incorrectly regarding dhcp then? I don't think I've manually installed dhclient but I'm not sure what's going on.
    – Devedse
    Feb 25, 2022 at 0:17
  • DO NOT post illegible pictures of text - post text.
    – Milliways
    Feb 25, 2022 at 0:36
  • Did this dhcpcd.conf workaround solve the issue? I'm experiencing exactly the same thing with a very similar setup; PI4, 64bit Raspberry OS, Docker with Portainer and a bunch of small containers.
    – mikaelnet
    Aug 10, 2022 at 18:35

1 Answer 1


This is an issue with DHCPCD & Docker on Raspberry, as you already found by yourself. The full discussion is here: Raspberry Pi 4: DHCPCD route socket overflowed. Basically, dhcpcd can be flooded when renewing IP addresses if too many interfaces are present. This is the case when Docker is installed and many containers/networks/services are running. In addition, docker take care of IP addresses and routing on its virtual network, so DHCPCD doesn't need to handle them.

The solution is to configure dhcpcd to ignore all interfaces whose name start with veth (Docker virtual interfaces).

Edit /etc/dhcpcd.conf and append the following line to the end

denyinterfaces veth*

Then restart the service:

sudo systemctl restart dhcpcd.service

Reference: https://github.com/raspberrypi/linux/issues/4092#issuecomment-774512217

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.