1

I did an upgrade from Debian Buster to Bullseye on a Raspberry PI Zero W. Now I can't connect to bluetooth devices anymore and can't pair. Also already paired devices don't work anymore.

I've tried deleting contents of /var/lib/bluetooth - didn't help.

If I install old bluez version and after reboot everything works fine sudo apt install bluez=5.50-1.2~deb10u2+rpt1

I've already tried sudo apt purge bluez and installed new version, didn't work.

I've setup a fresh debian bullseye installation in another Rasberry PI Zero W this works flawlessly. Packetversions are the same.

Not working raspberry PI Zero W

Removing bluetooth (5.55-3.1) ...
Removing pi-bluetooth (0.1.18) ...
Removing bluez (5.55-3.1) ...

Working one:

bluetooth/stable,now 5.55-3.1+rpt1 all [installed]
bluez/stable,now 5.55-3.1+rpt1 armhf [installed]
pi-bluetooth/stable,now 0.1.18 all [installed]
1
  • That's why the pi foundation never recommend upgrading major releases - because they haven't figured out how to do it properly. Raspberry Pi OS is "based" on Debian, but the pi foundation are inept
    – Bravo
    Mar 8, 2022 at 2:41

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.