0

I am trying to get an PICAN-FD-DUO-SMPS to work with a raspberry Pi 4B and cant quite get the can devices load.

I have updated the config.txt as such

dtparam=spi=on

dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25
dtoverlay=mcp2515-can1,oscillator=16000000,interrupt=24
dtoverlay=spi-bcm2835-overlay

after reboot, if I look at the log I see

dmesg | grep spi
[    6.279912] mcp251x spi0.1: MCP251x didn't enter in conf mode after reset
[    6.280127] mcp251x spi0.1: Probe failed, err=110
[    6.280212] mcp251x: probe of spi0.1 failed with error -110
[    7.294764] mcp251x spi0.0: MCP251x didn't enter in conf mode after reset
[    7.294883] mcp251x spi0.0: Probe failed, err=110
[    7.294925] mcp251x: probe of spi0.0 failed with error -110
  • I am not supplying the power from SMPS, but rather using the PI power supply

  • I have tried this on buster and bullseye - same results

  • I have tried this on RPI Zero 2W - same results.

  • I have tried only config can0, or can1 or both

  • I have tried lowering the frequency (spimaxfrequency=500000)

  • I have tried not specifying the dtoverlay=spi-bcm2835-overlay

  • I have tried dtoverlay=spi0-hw-cs

all of the have the same results of Probe failed, err=110

which seem to indicate to me that there was a timeout.

I also spend some time web crawling for similar problems. but most of the issues seem dated to older version of OS and older RPI models.

So my question is?

is there something I need to do for modern RPI models or do I simply have dead HW? If it's any consolation I can toggle the GPIO LEDS as well talk talk to the I2C RTC - and yees I know that that is a different circuit.

what did I miss?

many thanks

1 Answer 1

0

OK it turns out that I need to use an different overlay for the PICAN-FD

dtparam=spi=on

dtoverlay=mcp251xfd,spi0-0,interrupt=25
dtoverlay=mcp251xfd,spi0-1,interrupt=05

and now it works! many thanks to Sukkin at SK Pang Electronics Ltd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.