0

I have a Raspberry Pi 4 with 4GB of Ram

Linux: Linux raspberrypi 5.4.79-v7l+

Since 2020 I'm using my Raspberry as a small home server and it worked great with deConz smart-home and unifi and more.

But since the beginning, I have had these horrible USB external devices Droppings and I tried nearly everything I could find on the internet.

The Raspberry Pi is running on a USB SSD.

First try:

  • I plugged in a second 1GB SSD as storage.

  • I plugged in a third HDD with a 3TB USB.

The Pi crashes and keeps dropping the HDDs because of power issues.

Second try:

  • I installed an external usb3 Hub with an external power supply.
  • I plugged a 4,5Ah Power supply into the Pi and another 4,5Ah Power supply into the USB Hub and plugged the 3HDDs into the hub.
  • One of the HDDs is dropping all the time with the dmesg notification saying: Bad Cable.

But the problem doesn't appear when I plug the HDD directly into the pi, it's only with the hub.

Third try:

  • I plugged the Raspberry Boot SSD into the USB2 Port of the Raspberry Pi.
  • I plugged the 1TB USB3 SSD into the USB3 Port of the Pi.
  • I mounted the HDD and waited some days.
  • Without using it, without accessing the storage or anything, it's mounted in a directory and not more.

The 1TB Storage dropped the connection with DMESG:

Buffer I/O error on dev sdb1, logical block 36, async page read

And after the connection loss, it connects again with a new storage mount point.

/dev/sdb is now /dev/sdc

When I mount /dev/sdc, after some days I get the same error and then it's mounted as /dev/sdd, and so on.

I thought the HDD is maybe corrupted, after all these losses, but there are no errors on the HDD or the external case.

Smart Control result of the SSD: sudo smartctl -a /dev/sdc

enter image description here

When I use the 2 external storage USB devices on my laptop or an Intel NUC this behavior never happens.

I already bought 2 new cases and a new USB Hub, no changes.

It's driving me crazy. Is there anything I can do to find the reason for these drops?

I already used Y-cables with 2 USB power plugs.

I used an SD card instead of the main boot SSD and plugged the external HDDs into the Pi.

I updated the latest Raspberry Pi kernel and "bios" (firmware)

Somebody told me that the hub may be injecting power into the Raspberry Pi port and the Pi crashes, but this was the reason why I tried it with USB 2 and usb3 and without the HUB

1
  • 3
    All of the USB sockets are wired to the same common power rails, using a Y-connector does nothing useful. You're restricted to 1200mA across ALL USB devices. Use an external power supply for the devices that exceed your power budget.
    – Dougie
    Commented Mar 15, 2022 at 19:28

4 Answers 4

0

it seems to be a power issue and I would do two things:

  1. get a USB power meter to understand where power might be missing
  2. check your USB power supplies to make sure these are not USB chargers as these adapt their delivery which might have adverse effects
0

Make sure the firmware of your enclosures is up-to-date! I had the same problem with my NVMe SSD enclosure with a JMicron JMS583 chipset – the connection kept dropping on my Pi 4 (which never happened when connected to a laptop) even though the SSD was getting more than enough power from a USB hub.

Turns out the vendor firmware the enclosure shipped with was actually based on an older version of the chipset manufacturer's firmware; since replacing it with the newest firmware directly from the manufacturer I haven't had any more issues.

P.S. Depending on the chipset, you might need to remove the SSD if you don't want to risk data loss.

0

I may be a little late and I don't have a solution either. But here's what I was able to do with my setup. I wanted to use two WD-Red hard drives in a RAID1 array on my RaspberryPi 4 8GB. To connect the hard drives, I used ACTIVE SATA USB adapters, each with its own power supply. Each adapter was plugged into its own USB 3.0 port on the Raspberry Pi. Setting up the RAID array and synchronization worked flawlessly. However, as soon as I tried to copy my data to the disks (i.e. a high load on the disks), one disk was ejected (always the same disk) and immediately mounted again. However, with a different drive name. Since each time the RAID array had to resynchronize, this was not a solution for me. USB-quirks etc. I have considered everything. The only solution I could think of was an additional USB3.0 HUB. This I also bought. So both hard drives with active adapter were plugged into an active USB 3.0 hub, which was then also plugged into a USB3.0 port of the Raspberry. However, I observed exactly the same Fehlverhaten again. However, it does NOT occur when I run the disks (or only one of them) on a USB 2 port.

Maybe my information will help future people. Unfortunately, I have not found a solution to this problem. My original post about it can be seen here. Maybe something useful will come there in the course of time. Getting IO errors while connecting a HDD to a RPi4 when using USB 3.0 but not when using USB 2

0

I had similar problems with 4 USB drives connected to a Pi4 file server, which were failing during drive to drive rsync operations. I thought at first it was because one of the drives was formatted as exfat and another as ntfs, but after seeing some advice to use a powered USB 3.0 hub, I tried that and the problem went away - the formatting was a red herring. So... use a USB3.0 powered hub and make sure it is plugged in to the USB 3.0 port on the Pi4, not one of the two USB2 ports. It's OK to have one USB3 drive plugged in to the second USB3.0 port on the Pi. On my system I now have a 16Tb WD Red Pro drive on the Pi port via a USB dock and the 4 X 12Tb external WD Elements drives on the hub giving about 60Tb of storage. I also have the power supplies for those drives on tp-link switches so that my backup procedure can power them up, mount them, do the backup with rsync, and power them down again after unmounting when finished. PS This is the hub I'm using: https://www.amazon.com/dp/B00SCX6I8A

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.