4

In order to test the patch linked to in the following post: https://github.com/raspberrypi/linux/issues/29#issuecomment-6884170 I need to compile a custom kernel for my Pi.

To do this, I followed the steps laid out here: http://elinux.org/RPi_Kernel_Compilation#Ubuntu_Linux

This all worked fine and I was able to boot my Pi, however now my wireless adapter has ceased to work (worked previously by adding ath9k and ath9k_htc to my rc.conf) and dmesg tells me: "Loading user specified modules: FAIL". Taking a look at lsmod I can see that no (?!) modules are loaded!

I think this has to do with the kernel not having the correct paths to the modules.

So my question is, how do I build a kernel with the above mentioned patch for Arch Linux on my Pi?

I'm currently building on Ubuntu, but I could setup a virtual x86 arch Linux if that would make things easier.

  • Did you edit .config to compile ath9k and ath9k_htc as a module? – ArchHaskeller Jul 31 '12 at 17:06
  • Perhaps you didn't compile any modules? Did you run make modules_install when compiling the kernel? – Jivings Jul 31 '12 at 18:18
2

Turned out that all that was needed was to create a symlink to /lib/modules/KERNEL_VERSION in /usr/lib/modules.

Seems that Arch Linux likes to keep modules in this directory.

  • Ah of course, modudules… ;) – Jivings Aug 1 '12 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.