3

My ALSA sound volume gets mysteriously reset every time I do a reboot.

I set the default ALSA volume to 100% with amixer cset numid=3 100%. Then I do a reboot and check my amixer volume again and suddenly it's at 91%, or 87%, etc. I tried to store the current setting with sudo alsactl store, but that didn't help either.

Does that sound familiar to anyone? What could change the volume during the reboot process?

My system: Raspbian Wheezy, pulseaudio, and I start mplayer on @reboot via crontab.

1

You are supposed to mention your sound card number to store the settings using sudo alsactl store,

You could see the card number of your device using the command,

arecord -l

The output would be apparaently in this form,

List of CAPTURE Hardware Devices

card 1: U0x41e0x30d3 [USB Device 0x41e:0x30d3], device 0: USB Audio [USB Audio]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 1, in the above output indicating the number of your card.

Now, In order to save the settings that you have modified in card 1,

sudo alsactl store 1 
  • Thanks for this. I tried it for my card number 0 and then did a reboot, but the amixer volume was different again. Went from 100% to 91%. – evsc Feb 15 '14 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.