0

I have just set up my new raspberry system. However, my pip cannot install anything. Keep showing 'WARNING: pip is configured with locations that require TLS/SSL, however, the SSL module in Python is not available.' and 'Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.'

This makes me unable to do anything right now. I wonder if someone knows how to figure this out? Thank you so much!

enter image description here

6
  • What happens if you use pip3 instead of pip? Pip is for Python 2.x and is no longer supported. Mar 23 at 19:35
  • 1
    your question is not about Raspberry Pi ... it is about python and linux
    – jsotola
    Mar 23 at 19:56
  • what o/s are running? desktop or headless? 64 bit or 32 bit? bullseye or buster? Have you ran an update/upgrade?
    – dbmitch
    Mar 23 at 20:46
  • Also what do you get if you run pip --version and pip3 --version
    – dbmitch
    Mar 23 at 20:52
  • 1
    DO NOT paste illegible pictures of text - paste text.
    – Milliways
    Mar 24 at 6:54

1 Answer 1

0

Don't bother with pip run

sudo apt install python3-numpy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.