1

Its been quite a while since my last raspberry pi project. I went ahead and bought a new Rpi 4B and installed a fresh Raspbian OS on it and installed qt the way i remember it

$ sudo apt-get install qt5-default  #This does not work anymore i used an alternative
$ sudo apt-get install qtcreator
$ sudo apt-get install qtdeclarative5-dev

But its not as straight forward as i remember it anymore.

when i created a qt Application the desktop kit is greyed out

enter image description here

And upon further investigation it would seems that i do not have a qt version

enter image description here

Under the qt Version tab i dont have an item listed. How do i add a qt version?

enter image description here

It ask for a qmake executable and i do not know where its path is

7
  • qt version is the version of installed Qt
    – jsotola
    Mar 27, 2022 at 17:57
  • @jsotola there is no option to pick/write anything. adding a version will ask for a file. where is that file?
    – DrakeJest
    Mar 27, 2022 at 18:25
  • @jsotola yes i have read that guide, my problem is in the step 2.Select the qmake executable for the Qt version that you want to add. I do not know where that location is in my pi directory. Both options of "Add" and "Link with Qt" asks for a file/directory that i do not know where it is
    – DrakeJest
    Mar 27, 2022 at 19:02
  • then, why is your title qtcreator desktop kit is greyed out ... it would make more sense to be how to find qmake executable?
    – jsotola
    Mar 27, 2022 at 19:13

1 Answer 1

0

I solved it by first running

$ which qmake

it should show you a location of qmake, now go to

Tools > Options > Kits > Qt version > Add 

On the pop up, navigate to qmake location and then add. Now go back to

Tools > Options > Kits > Kit > scrool to qt version > qt 5  should now be an option there.

Although you may now solved the desktop app being grey, the project i had doesnt run because of clang. Just go ahead and install that one too

$ sudo apt install clang
1
  • this hasn't worked for me. i installed latest raspi 64 bit os (regular non minimal) on my raspi 4b Linux raspberrypi 5.15.32-v8+ #1538 SMP PREEMPT Thu Mar 31 19:40:39 BST 2022 aarch64 GNU/Linux I've tried sudo apt install qtcreator and the menu / preferences / add/remove software - search qtcreator, check, apply qmake is in the path, but when i Add it, it's a softlink that points to a nonexistent binary is there something else i need to sudo apt install? build-essential is already there. and several libqt5*5 libraries are installed with qtcreator May 30, 2022 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.