1

I am new to the forums and Linux in general. I am currently running Debian Wheezy with the GUI enable. For administrative purposes and other related tasks, I want to discontinue the use of the default user account "pi". Additionally, I would like to autologin a newly create user to the GUI desktop.

I created a new user and enabled sudo rights via the sudo visudo command and I commented out the "pi" user account line.

SomeUSER ALL=(ALL) NOPASSWD: ALL

I edited this file "/etc/inittab" to include the new user

1:2345:respawn:/sbin/getty --autologin SomeUser --noclear tty1

I edited this file "/etc/passwd" and change the "pi" user to the new user. This change seems to prevent the GUI desktop from loading.
SomeUser:x:1000:1000:,,,:/home/SomeUser:/bin/bash

What am I doing wrong that is not allowing the newly created user to autologin to the GUI desktop?

  • I believe I figured this out. Reviewing the commands in this link linkshows that editing rc.local and adding the command su -l USERNAME -c start x Can someone explain why this works with respect to adding the "startx" command? I would have expected to see the "startx" command already in the rc.local file if I initially executed the raspi-config to enable the GUI – Jordan Feb 17 '14 at 13:58
1

I believe I figured this out. Reviewing the commands in this link shows that editing rc.local and adding the command su -l USERNAME -c start x

Can someone explain why this works with respect to adding the "startx" command? I would have expected to see the "startx" command already in the rc.local file if I initially executed the raspi-config to enable the GUI

0

Your question is rather confusing. If you are asking how to enable/disable GUI on logon execute sudo raspi-config where you will find a menu to set this.

  • Essentially, I want to stop using the default user account "pi" and use the new user account I created. Enabling the GUI from raspi-config automatically logs you onto the GUI using the "pi" account. How do I automatically logon to the GUI using the newly created account? – Jordan Feb 14 '14 at 23:21
0

Edit /etc/lightdm/lightdm.conf

Change autologin-user to the new user.

Restart X or reboot.

0

Paul Crabb's method of editing the /etc/lightdm/lightdm.conf file works.

I used the raspi-config to enable automatically booting to the desktop with the PI user, then from terminal type: sudo nano /etc/lightdm/lightdm.conf

find the line for autologin-user=pi and change pi to the desired username. ctrl+x to exit, Y to save.

reboot the pi. (sudo shutdown -r now) and it should boot into the desired user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.