0

I recently re-installed Raspian. Before it was working without a hitch. Now when I boot it up for the first time, it gets to the Raspi-Config screen and I can't go anywhere because the keyboard doesn't work. It is the same keyboard that I used on it before, it's even the keyboard I'm using now. I also have tried other keyboard.

I then looked up the problem, people with the same problem have reported that it's a power problem so I made sure I had 5V and 1A and I tried that with multiple power supplies. Nothing.

Can anyone suggest a reasoning?

  • 1
    I would try to configure my Keyboard using SSH (PuTTY, if you're using windows). – Tico Feb 15 '14 at 2:15
  • Does the keyboard get power? i.e. does numlock/caps lock light go on or off, that to me would suggest power is ok, in either case, i'd go with @Tico suggestion of using SSH to run raspi-config – kolin Feb 19 '14 at 8:25
  • @kolin Just a reminder: I use a Logitech K800, it requires a receiver and it always worked fine. I don't see power as a problem. – Tico Feb 19 '14 at 17:51
  • Can you see if the keyboard registered on startup? – Beta Decay May 5 '14 at 5:50
1

The Pi uses 5W just for itself (5V and 1A). Therefore you need more amps to power a keyboard as well. Use 5V 1.6A and this hopefully will solve your problem.

1

As exantas mentioned, the Pi uses 5W just for itself. What I would do is get a powered USB hub. You can also get a power supply with more amps, like exantas suggested, but a powered USB hub will allow you to use mice, flash drives, wifi adapters, and other power-drawing peripherals easily.

Good Luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.