I have headless Raspberry Pi 4B 4GB Bullseye connected over USB-C to iPad Pro and I am using VNC to connect to it directly over a USB-C cable which also powers it. I have increased GPU memory to 256 and I am at 1024 resolution. However the performance of the system over VNC is unusable.

I have noticed that the performance gets fluent if I use raspi-config to switch to composite video but that of course has resolution limit to 720 which is too small and it displays as a small view in a corner of the iPad.

I have also tried switching to NoMachine but it doesn’t seem to help. I have bought the Raspberry to be used this way with my iPad but I can’t seem to resolve the performance issue. Can you please advice?

  • Seems to be related to video drivers that came with Bullseye update. I switched to Twister OS 32 bit and there is no issue with it, great to work with.
    – Ragnar
    Apr 4, 2022 at 6:30
  • I've used NoMachine at 1920x1080 on a Pi 4 connected via Cat8 ethernet and that's fine..
    – goldilocks
    Sep 23 at 13:31

1 Answer 1


Out of the box, it works perfect, once you update the drivers it becomes extremely slow, So install a fresh OS and don't update the video drivers until they are fixed I have tried a few suggestions on the web, for some it worked, but for me, none of them worked. Only fresh install and no updates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.