0

Update: I found that I couldn't find a arm64 for chrome remote desktop. Thanks Ccode!

I am having issues based on installing deb files on the raspberry pi os. I get errors when I attempt to install something. For example: I attempted to install Chrome Remote Desktop, but it ask to install soo much apps that I can't install on the raspberry pi. I tried installing the things it wants, and apt suggested that I should use a command to repair the app. I did it, but it says it can't install everything else. I expected that It will install all of it, but it didn't. My Dad has told me that the raspberry pi may not be meant to install these, but I was wondering if maybe there is some way to bypass these errors?

Thanks!

Using Raspberry pi 4 with raspberry pi os

UPDATE INFO:

I tried to update the architecture, but did not work. There is specific parts of the app that I can't download.

Here is the command log:

pi@raspberrypi:~/Downloads $ sudo dpkg -i chrome-remote-desktop_current_amd64.deb 
(Reading database ... 92141 files and directories currently installed.)
Preparing to unpack chrome-remote-desktop_current_amd64.deb ...
Unpacking chrome-remote-desktop:amd64 (99.0.4844.11) over (99.0.4844.11) ...
dpkg: dependency problems prevent configuration of chrome-remote-desktop:amd64:
 chrome-remote-desktop:amd64 depends on xbase-clients.
 chrome-remote-desktop:amd64 depends on python3 (>= 3.5).
 chrome-remote-desktop:amd64 depends on python3-psutil.
 chrome-remote-desktop:amd64 depends on libc6 (>= 2.17).
 chrome-remote-desktop:amd64 depends on libcairo2 (>= 1.2.4).
 chrome-remote-desktop:amd64 depends on libdbus-1-3 (>= 1.9.14).
 chrome-remote-desktop:amd64 depends on libexpat1 (>= 2.0.1).
 chrome-remote-desktop:amd64 depends on libgbm1 (>= 8.1~0).
 chrome-remote-desktop:amd64 depends on libgcc1 (>= 1:3.0).
 chrome-remote-desktop:amd64 depends on libglib2.0-0 (>= 2.31.8).
 chrome-remote-desktop:amd64 depends on libgtk-3-0 (>= 3.9.10).
 chrome-remote-desktop:amd64 depends on libnspr4 (>= 2:4.9-2~).
 chrome-remote-desktop:amd64 depends on libnss3 (>= 2:3.22).
 chrome-remote-desktop:amd64 depends on libpam0g (>= 0.99.7.1).
 chrome-remote-desktop:amd64 depends on libpango-1.0-0 (>= 1.14.0).
 chrome-remote-desktop:amd64 depends on libx11-6.
 chrome-remote-desktop:amd64 depends on libxcb1 (>= 1.9.2).
 chrome-remote-desktop:amd64 depends on libxdamage1 (>= 1:1.1).
 chrome-remote-desktop:amd64 depends on libxext6.
 chrome-remote-desktop:amd64 depends on libxfixes3.
 chrome-remote-desktop:amd64 depends on libxrandr2.
 chrome-remote-desktop:amd64 depends on libxtst6.

dpkg: error processing package chrome-remote-desktop:amd64 (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for mailcap (3.69) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Errors were encountered while processing:
 chrome-remote-desktop:amd64
pi@raspberrypi:~/Downloads $ sudo apt install xbase-clients
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 chrome-remote-desktop:amd64 : Depends: xbase-clients:amd64 but it is not installable
                               Depends: python3:amd64 (>= 3.5) but it is not going to be installed
                               Depends: python3-psutil:amd64 but it is not going to be installed
                               Depends: libc6:amd64 (>= 2.17) but it is not going to be installed
                               Depends: libcairo2:amd64 (>= 1.2.4) but it is not going to be installed
                               Depends: libdbus-1-3:amd64 (>= 1.9.14) but it is not going to be installed
                               Depends: libexpat1:amd64 (>= 2.0.1) but it is not going to be installed
                               Depends: libgbm1:amd64 (>= 8.1~0) but it is not going to be installed
                               Depends: libgcc1:amd64 (>= 1:3.0)
                               Depends: libglib2.0-0:amd64 (>= 2.31.8) but it is not going to be installed
                               Depends: libgtk-3-0:amd64 (>= 3.9.10) but it is not going to be installed
                               Depends: libnspr4:amd64 (>= 2:4.9-2~) but it is not going to be installed
                               Depends: libnss3:amd64 (>= 2:3.22) but it is not going to be installed
                               Depends: libpam0g:amd64 (>= 0.99.7.1) but it is not going to be installed
                               Depends: libpango-1.0-0:amd64 (>= 1.14.0) but it is not going to be installed
                               Depends: libx11-6:amd64 but it is not going to be installed
                               Depends: libxcb1:amd64 (>= 1.9.2) but it is not going to be installed
                               Depends: libxdamage1:amd64 (>= 1:1.1) but it is not going to be installed
                               Depends: libxext6:amd64 but it is not going to be installed
                               Depends: libxfixes3:amd64 but it is not going to be installed
                               Depends: libxrandr2:amd64 but it is not going to be installed
                               Depends: libxtst6:amd64 but it is not going to be installed
 xbase-clients : Depends: x11-apps but it is not going to be installed
                 Depends: x11-session-utils but it is not going to be installed
                 Depends: x11-utils
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
pi@raspberrypi:~/Downloads $ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libfuse2
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
  chrome-remote-desktop:amd64
0 upgraded, 0 newly installed, 1 to remove and 4 not upgraded.
1 not fully installed or removed.
After this operation, 48.7 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.
pi@raspberrypi:~/Downloads $ sudo dpkg --add-architecture amd64
pi@raspberrypi:~/Downloads $ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libfuse2
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
  chrome-remote-desktop:amd64
0 upgraded, 0 newly installed, 1 to remove and 4 not upgraded.
1 not fully installed or removed.
After this operation, 48.7 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.
pi@raspberrypi:~/Downloads $ sudo dpkg -i chrome-remote-desktop_current_amd64.deb 
(Reading database ... 92141 files and directories currently installed.)
Preparing to unpack chrome-remote-desktop_current_amd64.deb ...
Unpacking chrome-remote-desktop:amd64 (99.0.4844.11) over (99.0.4844.11) ...
dpkg: dependency problems prevent configuration of chrome-remote-desktop:amd64:
 chrome-remote-desktop:amd64 depends on xbase-clients.
 chrome-remote-desktop:amd64 depends on python3 (>= 3.5).
 chrome-remote-desktop:amd64 depends on python3-psutil.
 chrome-remote-desktop:amd64 depends on libc6 (>= 2.17).
 chrome-remote-desktop:amd64 depends on libcairo2 (>= 1.2.4).
 chrome-remote-desktop:amd64 depends on libdbus-1-3 (>= 1.9.14).
 chrome-remote-desktop:amd64 depends on libexpat1 (>= 2.0.1).
 chrome-remote-desktop:amd64 depends on libgbm1 (>= 8.1~0).
 chrome-remote-desktop:amd64 depends on libgcc1 (>= 1:3.0).
 chrome-remote-desktop:amd64 depends on libglib2.0-0 (>= 2.31.8).
 chrome-remote-desktop:amd64 depends on libgtk-3-0 (>= 3.9.10).
 chrome-remote-desktop:amd64 depends on libnspr4 (>= 2:4.9-2~).
 chrome-remote-desktop:amd64 depends on libnss3 (>= 2:3.22).
 chrome-remote-desktop:amd64 depends on libpam0g (>= 0.99.7.1).
 chrome-remote-desktop:amd64 depends on libpango-1.0-0 (>= 1.14.0).
 chrome-remote-desktop:amd64 depends on libx11-6.
 chrome-remote-desktop:amd64 depends on libxcb1 (>= 1.9.2).
 chrome-remote-desktop:amd64 depends on libxdamage1 (>= 1:1.1).
 chrome-remote-desktop:amd64 depends on libxext6.
 chrome-remote-desktop:amd64 depends on libxfixes3.
 chrome-remote-desktop:amd64 depends on libxrandr2.
 chrome-remote-desktop:amd64 depends on libxtst6.

dpkg: error processing package chrome-remote-desktop:amd64 (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for mailcap (3.69) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Errors were encountered while processing:
 chrome-remote-desktop:amd64
7
  • Are you sure you're installing the debs for the correct architecture (arm, not amd / x86)
    – Dirk
    Commented Apr 1, 2022 at 15:28
  • It says that I don't have the right architecture, and then I change it. still doesn't work. Note that more things needed to get installed in order for the app to be fully working.
    – LilData777
    Commented Apr 1, 2022 at 15:31
  • What do you change? Find a deb with the correct architecture? Please an example to your query with full commands and output (error messages)
    – Dirk
    Commented Apr 1, 2022 at 15:37
  • I did the command: sudo dpkg --add-architecture [architecture I need to have for deb file]
    – LilData777
    Commented Apr 1, 2022 at 16:11
  • Pls re-read my previous comment... add full commands and msgs to your question. Your last command is of very limited value.. BTW: changing architecture on your Pi will not e.g. make an intel deb work on a Pi...
    – Dirk
    Commented Apr 1, 2022 at 17:13

1 Answer 1

0

looks like your installing for the wrong arch. Try downloading the file for armvl7 or arm and running again.

6
  • I don't see where you see that I didn't install the right one. it wants amd64, and I did that.
    – LilData777
    Commented Apr 2, 2022 at 2:24
  • ` it wants amd64` Don't think so. You added amd64 so that's what it tries to install, As stated above it's the wrong (incompatible) architecture
    – Dirk
    Commented Apr 2, 2022 at 15:20
  • 1
    @Friendlygabe777 Raspberry pi is arm not amd. Your can't run a intel app on an arm computer.
    – Ccode
    Commented Apr 2, 2022 at 20:14
  • Did not work. said the architecture did not exist.
    – LilData777
    Commented Apr 4, 2022 at 11:18
  • On what? The pi or the website you were getting it off of?
    – Ccode
    Commented Apr 5, 2022 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.