2

I'm using the Adafruit Webide and logged into my rpi as webide@raspberrypi

I'm trying to add the directory of my node installation to the $PATH but I can't do it.

Every time I reboot and try env I get nothing.

I've tried adding the directory to /etc/profile and /home/webide/.bash_profile but neither work.

Any ideas what I'm doing wrong?

PATH=NODE_JS_HOME=/usr/share/adafruit/webide/repositories/node-v0.10.2-linux-arm-pi                                                                            
PATH=$PATH:$NODE_JS_HOME/bin                                                                                                                                      
export PATH 
2
PATH=NODE_JS_HOME=/usr/share/adafruit/webide/repositories/node-v0.10.2-linux-arm-pi                                                                            

Here you went wrong. It will not work with multiple equals signs. Please try

NODE_JS_HOME=/usr/share/adafruit/webide/repositories/node-v0.10.2-linux-arm-pi  
PATH=$PATH:$NODE_JS_HOME

EDIT:

If the new PATH is exported via .bash_profile, the changes are not effective immediately. Try

source .bash_profile
| improve this answer | |
  • Now I have this file: /home/webide/.bash_profile containing NODE_JS_HOME=/usr/share/adafruit/webide/repositories/node-v0.10.2-linux-arm-pi PATH=$PATH:$NODE_JS_HOME/bin export PATH Still doesn't work! – user1714819 Feb 15 '14 at 5:56
  • I reinstalled node in a more sensible location to get around the problem. I feel dirty for not getting to the bottom of this one but life is short..... – user1714819 Feb 15 '14 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.