0

I have Raspberry pi 3 B+ wich I haven't used for a long time. With Kali Linux (2019) installed. Today I tried to check it. It loaded and worked fine, but there were too many packages to update. During the update process via ssh I got a few errors and after one of them I lost the connection and had to reboot.

After that, new errors appeared during boot related to Journal Service and the Hardware Clock. Apt-get started to notify me "Release file for is not valid yet (invalid for another 180h 32min 20s). Updates for this repository will not be applied."

After the next reboot Raspberry Pi didn't boot. GPIO is detached.

dwc_otg.fiq_fix_enable=2 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait rootflags=noload net.ifnames=0 fsck.mode=force

The keyboard is not responding, so, I am not able to run any command. I didn't find how to open a command line.

RPi says I am in emergency mode and asks me for a root password. But the prompt is not available, it is not reacting, altho at this stage system does something and shows me when I connect and disconnect the keyboard for example.

Guys, look at the screenshot. Do you have any ideas how to restore OS without reinstalling it?

Thanks.

Won't boot :(

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.