0

I installed pigpio library and performed recommended tests after installation. I got some errors after installation:

command sudo ./x_pigpio returns errors:
    Waveforms & serial read/write tests.
    TEST  5.4  FAILED got 25 (callback: 50)
    TEST  5.11 FAILED got -142 (wave tx busy, serial read: 0)

command ./x_pigpiod_if2 returns errors:
    Waveforms & serial read/write tests.
    TEST  5.4  FAILED got 26 (callback: 50)
    TEST  5.10 FAILED got 1730 (wave tx busy, callback: 1702)
    TEST  5.11 FAILED got -142 (wave tx busy, serial read: 0)

command ./x_pigpio.py returns errors:
./x_pigpio.py
    Waveforms & bit bang serial read/write tests.
    TEST  5.4  FAILED got 25 (callback: 50)
    TEST  5.10 FAILED got 1728 (wave tx busy, callback: 1702)
    TEST  5.11 FAILED got 0 (wave tx busy, serial read: 1)
    TEST  5.26 FAILED got 25 (callback: 50)
    Wavechains & filter tests.
    TEST 13.7  FAILED got 2688 (glitch filter, wave chain, tally: 1792)
    TEST 13.8  FAILED got 1792 (glitch filter, wave chain, tally: 896)
    TEST 13.9  FAILED got 1792 (glitch filter, wave chain, tally: 0)
    TEST 13.10 FAILED got 743 (noise filter, wave chain, tally: 1500)
    TEST 13.12 FAILED got 13 (noise filter, wave chain, tally: 0)

command ./x_pigs returns errors:
    SLR-f fail with [23 230 158 134 6 24 158 6 102 158 102 6 152 152 230 
                     248 6 24 230 230 158 6 134 158]
    ERROR: No more CBs for waveform

command ./x_pipe returns errors:
    LR-f fail with (23 230 158 134 6 24 158 6 102 158 102 6 152 152 230 
                    248 6 24 230 230 158 6 134 158)

RPI 3 B+, pigpio 79, GPIO unconnected, sound unused. What does it mean? How these errors could be fixed (if could be)? Are these errors critical? Which possibilities of pigpio lib will work incorrectly?

4
  • Have you got anything connected to the GPIO or are you using sound (PWM or PCM based)?
    – joan
    Apr 13 at 14:52
  • GPIO unconnected and sound unused
    – mock_up
    Apr 13 at 17:13
  • Could you add that information to the question as well as the model of Pi and the pigpio version (pigpiod -v).
    – joan
    Apr 13 at 17:24
  • Raspberry pi 3 B+, pigpio version 79
    – mock_up
    Apr 13 at 17:34

1 Answer 1

0

I have not heard of any problems with the Pi3B+.

Could you run gpiotest to check the GPIO.

1
  • I run gpiotest, results are: Testing... Skipped non-user gpios: 0 1 28 29 30 31 Tested user gpios: 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 Failed user gpios: None
    – mock_up
    Apr 13 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.