0

Using docker on a PI3, I need to rebuild an image which uses Alpine 3.6 - but I get an error. The URL is fine, but when a CURL it, it shows a redirect. I've tried 3.9 and 3.10 as well, but I believe I get similar errors.

What's the easiest fix for me to do, or do I just wait for someone to fix it? I am looking for alternative images so for Python for armv7.

If I run the same Docker file on a x64 machine, it all works fine.

Using python:3.8.2-alpine on the RPI seems to be an easy workaround.

peter@pi0050:~/docker/mycontainersource $ sudo docker build -t mycontainer:v001 .
Sending build context to Docker daemon  114.7kB
Step 1/12 : FROM python:3.6-alpine
 ---> 7461863c4c27
Step 2/12 : RUN apk update
 ---> Running in 62ebf938895e
fetch https://dl-cdn.alpinelinux.org/alpine/v3.14/main/armv7/APKINDEX.tar.gz
ERROR: https://dl-cdn.alpinelinux.org/alpine/v3.14/main: temporary error (try again later)
WARNING: Ignoring https://dl-cdn.alpinelinux.org/alpine/v3.14/main: No such file or directory
fetch https://dl-cdn.alpinelinux.org/alpine/v3.14/community/armv7/APKINDEX.tar.gz
ERROR: https://dl-cdn.alpinelinux.org/alpine/v3.14/community: temporary error (try again later)
WARNING: Ignoring https://dl-cdn.alpinelinux.org/alpine/v3.14/community: No such file or directory
2 errors; 35 distinct packages available
The command '/bin/sh -c apk update' returned a non-zero code: 2

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.