1

After a significant amount of struggle I managed to connect my Raspberry Pi 3B to my university's WPA2 Enterprise network, UCR-SECURE, in the traditional set-up with a monitor, keyboard, and mouse; however, when I attempted to use the Raspberry Pi in a headless set-up there was no connection to UCR-SECURE. I would prefer to use the Raspberry Pi in a headless set-up, does anyone know why this is happening and how I can fix it?

Note: I connected to my university's WPA2 Enterprise network with the monitor by changing the GUI with network manager which allowed me to select the correct settings for connecting to WPA2 Enterprise:

sudo apt install network-manager network-manager-gnome

Note: Had previously tried multiple renditions of a wpa_supplicant file with no success before moving to the monitor set-up, most lately this one:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
    ssid="UCR-SECURE"
    scan_ssid=1
    key_mgmt=WPA-EAP
    pairwise=CCMP
    group=CCMP
    eap=PEAP
    identity="MY_USERNAME"
    password="MY_PASSWORD"
    ca_cert="/etc/certs/UCR-SECURE-CERT.pem"
    phase1="peapver=0"
    phase2="MSCHAPV2"
}

1 Answer 1

0

It sounds like what might be happening is that in headless mode either NetworkManager isn't running or the system isn't able to access the WPA credentials.

To ensure NetworkManager is running, after enabling headless mode run sudo systemctl enable NetworkManager to enable it and sudo systemctl start NetworkManager to start NM. To check on NM's status in headless mode, you should be able to use the nmcli dev status command.

If it is a credentials issue, in the NetworkManager settings in the GUI there should be a tick box to allow other users to use this network, which could help.

See http://www.intellamech.com/RaspberryPi-projects/rpi_nmcli.html for additional details on using NetworkManager from the command line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.