I have a raspberry pi 4 8gb that has 3x SSD's attached via a powered hub, one of which is the boot drive, and if I turn it on with all 3 SSD's attached, it won't boot. I have two of the drives set to automount at boot and this is what my fstab file looks like:

roc            /proc           proc    defaults          0       0
PARTUUID=8f3d68ab-01  /boot           vfat    defaults,flush    0       2
PARTUUID=8f3d68ab-02  /               ext4    defaults,noatime  0       1
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that
UUID=fb79f173-d504-m333-0058-f073a949d601 /mnt/PIDRIVE ext4 defaults,auto,users,rw,nofail 0 0
UUID=D6AE7ED4AE7E9C25 /mnt/storage ntfs defaults,auto,users,rw,nofail 0 0

I've tried directly plugging the boot drive to the RPI and leaving the other SSD's attached to the hub and the same problem results. If I turn off the powered hub, wait a couple of seconds, and then turn it on (same as plugging them in), it boots and mounts them correctly.

I've already tried delaying the boot with /etc/rc.local

IP=$(hostname -I) || true
if [ "$_IP" ]; then
  printf "My IP address is %s\n" "$_IP"
sleep 20
sudo mount -a
exit 0

This also didn't help. I'm guessing this is happening because it misidentifies one of the other SSD's at the boot drive and it hangs for some reason? Is there any way to direct the Rpi to the correct SSD to boot?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.