0

TL;DR

Note: I have already read and applied all the steps described at the Boot Problems Sticky

  • Pi4B was working yesterday, "died" overnight.
  • Red LED on, but no green LED "activity" or HDMI output
  • Power-on without SD card should blink green LED 4 times, but nothing happens
  • Attempted re-flash of bootloader (from RPi Imager Utilities); no response
  • Also tried a new OS image on a different SD card
  • Checked TP1-TP2 voltage = 5.272v
  • Tried several micro-SD cards; all give the same (non-)result.

Details:

Relatively new Pi 4B (Jan 2022) running latest Raspberry PI OS (based on Bullseye, 64bit). It's in the small red/white case and not being used on a breadboard or otherwise being manipulated.

Power is the RPi 5.1v 3.0A adapter. The only other connections are Ethernet, HDMI and USB (Keyboard/Mouse). Input to the power adapter is a sine-wave UPS so I don't think a power glitch is to blame. The UPS software doesn't indicate a power outage overnight.

Yesterday afternoon I plugged in a TP-Link USB WiFi adapter (RTL8821AU), for which I am aware I will need to compile a driver. I hadn't gotten around to doing that yet. When I stopped for the evening yesterday the Pi was running and I had an SSH session connected from Windows.

This morning the system is "dead". The power light comes on when plugged in but there's no green Activity LED or HDMI signal. I did a thorough web search and found the troubleshooting checklist on the RPi Forums site.

One simple test is to remove the SD card and apply power. What is supposed to happen is that the green LED should blink 4 times, indicating that the SD card is missing, unreadable, or does not contain a bootable image. When I do this, the red LED comes on but I don't see any blinks on the green LED.

If that fails the RPi Forum suggests re-flashing the EEPROM, which I attempted without success. I used the Imager to create a Bootloader restore image and tried to boot from it as instructed. Same results, power light (red LED) comes on but no activity and no HDMI output, even after waiting several minutes past the expected 10-second time.

I have also tried all the above using two different 32gb micro-SD cards from different manufacturers. I also tried the beta bootloader that is offered in the Pi Imager, as well as a fresh OS image on a different SD card.

TP1-TP2 voltage is 5.272

I found this: https://willhaley.com/blog/dead-raspberry-pi/ which describes my symptoms, but I haven't been doing anything like that or attempting to power the board except from the standard power adapter via the USB-C connector.

Additional Data:

I found some info on test points and GPIO pins... looks like my 3.3v is dead. Using either GPIO pin 6 or the ethernet connector case as ground, I get 5.272v from GPIO pins 2 & 4, but zero volts from pin 1 or 17.

Question:

Could my Pi4B be totally fried, and if so what could have caused it to fail in in this way? Also, is there anything else I can do to troubleshoot this? Can I determine why the 3.3v bus is dead, and is this repairable?

2 Answers 2

0

I have this exact same issue and had tried everything you had except testing the goop pins, upon doing so I also have the exact same results. I also accidentally touched the 1, 21, and ground pins together and the green light appeared (it didn’t boot but I figured it might be worth mentioning). Did you ever find a solution and does the company have any type of warranty on these machines?

1
0

Posting an answer for future reference.

I finally gave up and tried to order a new Pi 4b, but at the time (May 2022), due to supply chain issues, it was no longer available. I purchased a Pi 5 last December.

There's supposed to be a 1 year warranty, but in my case, given the supply chain problems at the time, I doubt I'd have been able to get a replacement.

Oh well... live and learn.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.