3

I'm trying to attempt a Cross Grade (before I do a full wipe)

I did

sudo  dpkg --add-architecture arm64

But when I ran sudo apt update I got

N: Skipping acquire of configured file 'main/binary-arm64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' doesn't support architecture 'arm64'
N: Skipping acquire of configured file 'contrib/binary-arm64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' doesn't support architecture 'arm64'
N: Skipping acquire of configured file 'non-free/binary-arm64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' doesn't support architecture 'arm64'
N: Skipping acquire of configured file 'rpi/binary-arm64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' doesn't support architecture 'arm64'
6
  • 1
    Do a full wipe and get RaspiOS 64 Bullseye as a fresh install. What you're attempting to do is guaranteed to fail and waste your time.
    – Dougie
    Apr 24, 2022 at 11:47
  • 1
    Welcome. I guess it would be nice if someone could explain in detail why "what you're attempting to do is guaranteed to fail", but Dougie is probably right: Based the history of the OS, I'd give this a try but at the first roadblock give up. There are some unusual aspects to an RPi install that make vanilla Debian tools on this level very unlikely to work perfectly and somewhat likely to not work at all. Be happy you didn't waste too much time.
    – goldilocks
    Apr 24, 2022 at 14:35
  • ...That said, it is a reasonable question with an objective answer (even if no one here knows all the nitty-gritty) and the close votes are inappropriate in so-far-as the reason it doesn't work is probably Raspbian specific.
    – goldilocks
    Apr 24, 2022 at 14:35
  • why are you not asking about the error messages that you received?
    – jsotola
    Apr 24, 2022 at 16:56
  • Why not just spend $10 on a new SD Card and do a fresh install. NOTE you are unlikely to see ANY difference from 32 bit unless you want to install software which is unavailable in 32 bit.
    – Milliways
    Apr 24, 2022 at 22:51

3 Answers 3

3

Your error comes from the fact that you're targeting the wrong repositories. Raspbian has separate repositories for 32-bit (http://raspbian.raspberrypi.org/raspbian) and 64-bit (http://archive.raspbian.org/multiarch), which you have to specify in /etc/apt/sources.list Incidentally cross-grade is not going to be nearly as seamless as it is on Debian, if at all possible.

AFAIK the 64-bit OS also uses standard Debian repositories (http://deb.debian.org/debian) for non-Pi-specific packages.

3

It is possible but tricky. The way I did it is:

  1. boot with the 64-bit kernel,
  2. update the repositories,
  3. copy the apt metadata from the raspios image,
  4. reinstall all the packages with apt,
  5. delete the 32-bit executables that do not correspond to installed packages.

There were a few issues with file collisions etc, but this worked on the first attempt.

6
  • 1
    I guess you left out step 0: create a backup ;-) But thank you, that sounds promising, can you elaborate on 3), what meta data did you copy and where from?
    – WMR
    Oct 7, 2022 at 13:30
  • 1
    Copied /var/lib/apt from 2022-09-22-raspios-bullseye-arm64.img.
    – auxsvr
    Oct 7, 2022 at 15:26
  • @auxsvr With 2) update repositories you mean updating /etc/apt/sources.list and /etc/apt/sources.list.d/raspi.list to the 64 bit repositories, correct?
    – freeDom-
    Oct 29, 2022 at 21:13
  • 1
    Yes. Perhaps one can avoid it, as most repositories include both architectures.
    – auxsvr
    Oct 30, 2022 at 9:56
  • Did not work for me. Ended up with a broken system and having to reinstall OS to SD card.
    – Firefishy
    Nov 22, 2022 at 8:20
0

No Pi OS supports cross version upgrade LET ALONE cross grade.

There is no Raspberry Pi OS mechanism to install a different kernel and firmware which is radically different from the standard Debian distribution.

The release explicitly states it is not possible.

There is NO 64bit Raspbian - the recent Raspberry Pi OS are renamed because they diverge from Raspbian.

The 64bit version uses the standard Debian repository with Raspberry Pi specific kernel and firmware. If you are brave you could try editing sources to match the 64bit version and try full-upgrade but I would not anticipate success.

3
  • 1
    This is not actually true, we can upgrade from buster to bullseye. I just did it an hour ago. Raspberry Pi OS is just a rename of Raspbian and they have a 64-bit version now. Apr 24, 2022 at 23:01
  • @ArchimedesTrajano There is no supported upgrade. The unsupported process sometimes works but still requires manual fixes and actually takes longer than a fresh installation. I have done this for pre release testing but wouldn't consider the result reliable.
    – Milliways
    Apr 24, 2022 at 23:14
  • @Milliways I am running an upgraded pi from Buster to Bullseye since the release of Bullseye without any problems... Yes, it is not supported, but it definitely was faster for me to upgrade than to reinstall and setup my nextcloud and home assistant instances and restore all data... You are also wrong about installing a 64-Bit Kernel, which is pretty easy and supported. Just append arm_64bit=1 to your /boot/config.txt and restart. That's it.
    – freeDom-
    Oct 29, 2022 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.