When I download the macOS imager disk image from the Raspberry Pi OS page, and then double click it I get this error:

Corrupt image - Finder dialog

If I try to fix it in Disk Utility I get the same error:

Corrupt image - Disk Utility dialog

The issue is the same as described here, imager_1.4 - "corrupt image" on OS X 10.9.5, and no solution is provided, other than using dd.

Note that this fails on 10.8.5 and 10.9.5 but works on 10.13.6 - I haven't tested on anything in between.

FWIW, I've tried repairing the image in Disk Utility, hence the error shown above, as well as this Q&A on SU, Unable to open DMG files - "Corrupt Image", which is as equally ineffective.

Does anyone know why the disk image fails to mount? Is there a way of getting it to mount? Or another source of an uncorrupted image?

If you mount the disk image on 10.13.6 and then copy the binary to 10.9.5 (just to test if the binary will actually work), then upon running the imager binary, it fails with this message:

Application fails to run on 10.9.5


1 Answer 1


The issue isn't only the mounting of the disk image, it is also that the imager binary will not run on versions of OS X prior to 10.13.

As per CoderMike's comment, I posted the issue on github: imager not working on OS X #434, and this comment states

Although, there's still the option of building the Imager from source.

Not sure if that would be an option either for versions before 10.13. Even if you compile it against an older version of Qt (that support versions prior to OS X 10.13), chances are you may run into problems with OpenSSL. Chances are you need an older OpenSSL version to compile against the older version of Qt, and that may or may not speak a SSL flavour recent enough to be able to communicate with the webservers that host the images...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.