1

I'm using a rasperi pi 4 and want to run a water pump with it. Connecting the water pump directly to the rasperi pi (ground and 5 V) is working. But I want to be able to control the pump via GPIO and I also read somewhere that it isn't really healthy for the rasperi pi to connect a motor to it. (I'm pretty new.)

So basically I ordered some 5V relays(they are from Az Delivery if that helps). I think I have attached it correctly to the pi because if I turn on the GPIO 20 (connected to that one) on, I hear a click and the LED turns on. But the Waterpump isn't running. I ordered multiple relays and tried 3 already so I don't think they are broken. Is there a power issue? The waterpump was running when I connected it directly to the rasperi pi... And I also tried connecting the relay to the 3V on the pi, didn't work either

Here you can see the relay. I think the red led means that the relay is on.

1 Answer 1

3

This isn't how a relay works. The relay board is just a switch that can be turned on and off by a low power signal from a raspberry pi GPIO pin. You will need to provide a separate power source to power the pump.

Try using a 9V battery or similar to power the pump. Connect the +ve pump wire to the 'normally open' (NO) pin on the relay board, and the -ve wire from the pump to the -ve terminal on the battery. Connect the +ve battery terminal to the middle pin on the relay board. Then you should be able to use the GPIO pin to switch the pump circuit on and off.

1
  • 2
    The voltage of the battery or power supply should match the specification of the pump. If the pump works with 5V, then 9V might be too much.
    – Bodo
    May 10 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.