0

I am trying to set up a brushless motor so I can control it via python.

I have a AreoStar ESC and the manual says to enter the menu for the motor you must first set the throttle to 100%, then plug in the battery. A menu of beeps will be sounded and setting the throttle to 0 will then select and arm.

If I run the following command

pigs s 27 2500

plug in the power then... after the first set of 4 beeps run

pigs s 27 0 

all goes quiet. I was expecting a confirmation beep.

If I then try and run any other pigs command to move the motor I either get nothing. Sometimes I get continuous beeps. It feels like it is not armed.

If I unplug the battry and plug it back in I get nothing (I am guessing I should get a sound to say it is armed?). I can re-enter the menu at any time with the above.

Anythoughts on what I need to do to arm the motor?

7
  • The normal maximum would be 2000. Try that instead of 2500.
    – joan
    May 15, 2022 at 19:57
  • I had previously tried 2000, just tired again seems to have same effect unfortunately
    – John
    May 15, 2022 at 20:00
  • Okay. Instead of dropping to zero drop to the normal minimum of 1000.
    – joan
    May 15, 2022 at 20:15
  • Thanks will give that a go later
    – John
    May 16, 2022 at 7:08
  • @joan that worked!!! If you add it as an answer I will mark as correct. Thank you for your help.
    – John
    May 16, 2022 at 18:21

1 Answer 1

1

When arming the ESC it is looking for the upper and lower values to set the range. For some reason setting the lower range to 0 (where it sends no signal) was not acceptable. Therefore the following works...

pigs s 27 2000 (upper limit)

Wait for 4 beeps

pigs s 27 1000 (lower limit)

Then hear the confirmation beeps. Following this we can send it further commands to spin the motor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.