0

I had set up my Pi 3b as a NAS with the help of an external hard drive, powered by a USB hub. This worked for a week. Today after boot, I'm seeing the message:

You are in emergency mode. After logging in, type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or "exit" to boot into default mode.

Cannot open access to console, the root account is locked. See sulogin(8) man page for more details.

Press Enter to continue.

The only way to login to the Pi is to disconnect the hard drive. When I do that, and then reconnect the drive after login, I'm not seeing /dev/sda1 after running sudo blkid.

I already tried to fix it by editing /etc/fstab via this article to no avail. I had commented out a line made by OpenMediaVault, the program that runs the NAS.

1
  • Can you log in without the usb drive and check the log files. look at the /var/log/syslog.n(.gz) files to see what error messages are being issued. sudo tail -f /var/log/syslog then plug the usb drive in and see what messages appear. Post as much information as you can get and then someone may be able to help you May 22 at 10:04

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.