3

I'm on Raspberry Pi OS Bullseye, using a Pi 3B. The error message is differing from the ones I could find on previous posts, and there are different fixes by changing dtoverlay in /boot/config.txt. Last time I re-enabled the Legacy stack camera at least that worked but it completely bugged the whole system, making it impossible to connect via VNC and many other unrelated things... I could not find a solution to this, here's what it tells me:

libEGL warning: DRI2: failed to authenticate
Made X/EGL preview window
[0:13:54.365083754] [3458]  INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3544-22656360
[0:13:54.405175545] [3474] ERROR CameraSensor camera_sensor.cpp:591 'ov5647 10-0036': Camera sensor does not support test pattern modes.
[0:13:54.468034105] [3474]  INFO RPI raspberrypi.cpp:1356 Registered camera /base/soc/i2c0mux/i2c@1/ov5647@36 to Unicam device /dev/media3 and ISP device /dev/media0
[0:13:54.469572692] [3458]  INFO Camera camera.cpp:1029 configuring streams: (0) 1296x972-YUV420
[0:13:54.470488521] [3474]  INFO RPI libEGL warning: DRI2: failed to authenticate
Made X/EGL preview window
[0:13:54.365083754] [3458]  INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3544-22656360
[0:13:54.405175545] [3474] ERROR CameraSensor camera_sensor.cpp:591 'ov5647 10-0036': Camera sensor does not support test pattern modes.
[0:13:54.468034105] [3474]  INFO RPI raspberrypi.cpp:1356 Registered camera /base/soc/i2c0mux/i2c@1/ov5647@36 to Unicam device /dev/media3 and ISP device /dev/media0
[0:13:54.469572692] [3458]  INFO Camera camera.cpp:1029 configuring streams: (0) 1296x972-YUV420
[0:13:54.470488521] [3474]  INFO RPI raspberrypi.cpp:760 Sensor: /base/soc/i2c0mux/i2c@1/ov5647@36 - Selected sensor format: 1296x972-SGBRG10_1X10 - Selected unicam format: 1296x972-pGAA
terminate called after throwing an instance of 'std::runtime_error'
  what():  failed to import fd 19
Abgebrochen
raspberrypi.cpp:760 Sensor: /base/soc/i2c0mux/i2c@1/ov5647@36 - Selected sensor format: 1296x972-SGBRG10_1X10 - Selected unicam format: 1296x972-pGAA
terminate called after throwing an instance of 'std::runtime_error'
  what():  failed to import fd 19
Abgebrochen
 
4
  • Is Bullseye fully updated?
    – CoderMike
    May 31, 2022 at 9:16
  • @CoderMike Yes, it's the Full OS 32 bit version, installed updates while setting it up. Did sudo apt-get update and sudo apt full-upgrade.
    – user147054
    May 31, 2022 at 17:52
  • I suggest you post on the official forum under the camera board section: forums.raspberrypi.com/viewforum.php?f=43
    – CoderMike
    May 31, 2022 at 18:01
  • @CoderMode, uh thanks! gonna look into it
    – user147054
    May 31, 2022 at 18:11

2 Answers 2

0

Resolved the issue by enabling Glamor graphics acceleration as specified in the top red box in the official documentation (be sure to cool down Cpu with fan and heatsink as mine reached 83°C, while running the preview). If that doesn't fix it and the libcamera-hello command does not open the video preview, you might want to control that dtoverlay parameter is set according to your 3rd party camera module. Moreover you can try changing the Kms driver to fakekms. If that doesn't work and you run on a Raspberry Pi 3, with the Bullseye OS (as in my case) check out this thread which specifies to add the dtoverlay to the all section of /boot/config.txt`.

1
  • If your answer is correct, please accept it. Otherwise this question will keep reappearing.
    – NomadMaker
    Jul 1, 2022 at 18:33
0

I solved the problem by running sudo raspi-config, then "Advanced Options", then "GL Driver", "then select GL (Fake KMS)". I am using a Raspberry Pi 3 B+ with Raspberry Pi OS Buster.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.