0

This is really confusing for me. My Argon One case with M.2 SSD do not boot sometimes giving below error:

usb2-port2: Cannot enable. Maybe the USB cable is bad?
usb2-port2: Cannot enable. Maybe the USB cable is bad?

The frequency of boot failure is 1 out of 20 or 30 times but on random basis whenever RPi does its scheduled reboot during self-healing process or due to power outage. It never recovers until I do a hard reboot. It was running fine (with reboots) for an year or so but now its causing this strange, yet difficult to diagnose issue.

enter image description here

Here are possible reasons:

  1. Faulty USB 3.0 jumper adapter of Argon ONE case -> If its faulty, why it starts working back again on manual hard-reboot? Maybe the temperature cools down below 50 at that point. Normally its temerature stays between 51 to 53 degrees. However, if this is the case, why OS never crashes once its booted and catches temperatures up to 53 degrees. Why it only appears on reboot caused by power outage or scheduled reboot or manual reboot on random basis.
  2. Overlay File System -> Recently I enabled overlay filesystem with a separate partition as mount point. For 1 to 2 days, I have not received this error. That means it could have something to relate with some kernel bug which do not triggers since OS filesystem is freezed using overlay FS?
  3. Power Supply Issue -> I suspect during summers, power supply of official Raspberry Pi 4 might not be enough for Argon One M.2 case which was ok in winters because fan was in off state. Possibility is that power supply also have lost its efficiency with time.
  4. Faulty SSD -> I highly doubt that because system runs fine once it boots successfully and never crashes while running. Issue only appear during boot process.

PS: Pi4 is running Raspian OS 32 bit.

Can you share your thoughts on this?

2
  • This is perhaps a nitpick, but the case doesn't boot, the Raspberry Pi does.
    – NomadMaker
    Jun 18 at 16:40
  • I have a ARGON ONE V2 case without SSD where it boots via USB. Working fine since over a year now. I however managed to find the root-cause for this specific error in M.2 version Jun 18 at 17:07

1 Answer 1

0

I've got the same issue with my Argon one used for my home automation system.

It was working fine for months and I've suddenly got some random behavior with read errors on my SSD. Sometime it fails to reboot.

When I check the logs, I get exactly the same error.

I've tried to change the power supply with a 20W version, but upon restart I get stuck with the same error.

As I have another Argon One, I've switched the USB 3 jumper and it started immediately. However, as the error is somehow random, I can't be sure it is caused by the USB bridge (or some internal connection in the Argon?).

Nevertheless, I've ordered a high speed USB-A to USB-A cable and I will monitor the stability of the system.

So to sum up, I would say either option 1, or an additional option 5: Argon One case electronics.

1
  • Hello, apparently the error appeared again after a while. I turned out it only happened when I disabled overlay filesystem and rebooted machine for maintenance purpose. Whenever overlay FS is enabled, no matter how many times I have to reboot, never saw this error again. Jun 26 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.