1

I installed FreeBSD on my pi4 and now i am trying to setup ssh so i can ssh into it and run c files via my computer on the LAN. When i type in 'ifconfig' i get a lot of info but the important information is the IP i need, which does not appear to be present in the network interface...so im thinking i need to assign a static IP address since i do not currently have one. I can login to the computer using itself... but i can not login using another computer on the LAN, i do have root login permission enabled How can i login to my pi using my computer on the same network?

6
  • See 12.5. Setting Up Network Interface Cards. It's pretty straightforward. Then, 14.8. OpenSSH covers both configurations of the SSH client and server. If you want to configure WiFi see 32.3. Wireless Networking. Jun 6, 2022 at 4:15
  • See What works. Broadcom brcmfmac43455-sdio is not supported. See 'Hardware Notes' and find supported WiFi. For example FreeBSD 13.1-RELEASE Hardware Notes. Jun 6, 2022 at 4:40
  • See recent dmesg of RPi4 at FreeBSD 13.1-RC6. Jun 6, 2022 at 4:46
  • I installed freebsd on a pi 4 no dongle! Check /etc/rc.conf to ensure it has the lines. ifconfig_DEFAULT="DHCP" and sshd_enable="YES", this should configure the interface via DHCP.. here is my ifconfig output. genet0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500 options=68000b<RXCSUM,TXCSUM,VLAN_MTU,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6> ether dc:a6:32:64:ce:21 inet 192.168.192.120 netmask 0xffffff00 broadcast 192.168.192.255 media: Ethernet autoselect (1000baseT <full-duplex>) status: active nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL> Jun 6, 2022 at 19:35
  • @VladimirBotka: I'd like to encourage you to reformat some of your comments into an answer. I think it would really be helpful for those (like me) who'd like to branch out, and try other OS on our RPi hardware. I do have a question that perhaps you could add to your answer: Why is the arm hardware not listed here?
    – Seamus
    Jun 6, 2022 at 22:31

2 Answers 2

1

Welcome to RPi SE. It's great to see you're trying a non-standard OS on RPi. I wish you'd edit your question to add some links on where you got your download image, and how the installation went (briefly). I ask this because the information might encourage others to try FreeBSD; in general, switching to another OS is as simple as swapping SD cards.

That said, I wonder if ifconfig on FreeBSD is the same as ifconfig on Linux? If your experience to date is mostly with Linux, I think you'll find that using a Unix distro is a bit like dating your girlfriend's older sister :)... most things are similar, but not quite the same.

Another point to make is that I'll guess that many of those who ply the stacks here won't have much experience in other OS, particularly Unix. You might have better luck at the U&L SE, but as always it pays to do your homework before asking others to help you solve your problems.

2
  • the installation went well & i got my sd card image from the freeBSD site. ifconfig gives you a list of the interfaces and information pertaining to them. What is weird to me is that I was able to get wifi with raspbian OS no problem, but now i asked the guys at the freeBSD forum and they are saying I need a usb dongle
    – Noah
    Jun 6, 2022 at 9:43
  • @Noah: I just read some of the comments from VladimirBotka. He clearly has much more to offer in answer to your question than I - my last experience with FreeBSD was about 20 years ago! The reason you don't get wifi w/ FreeBSD is answered by Vladimir's comments: FreeBSD doesn't have a wifi driver. I'll stick my neck out again, and guess that's due to the proprietary nature of everything Broadcom! That said, at least you have eth0 to works with.
    – Seamus
    Jun 6, 2022 at 23:02
0
  1. Connect your Pi to the router using a cable.
  2. Open /etc/rc.conf and add the following lines: ifconfig_ue0="DHCP" sshd_enable="YES" Save and reboot
  3. Check your router for the list of connected hosts to find the IP address assigned to the Pi.
  4. Before you can SSH into the Pi, make sure you create a new user for your normal usage as FreeBSD does not allow the user named "root" to connect via SSH unless you edit /etc/sshd_config and enable that option.

You can also read this: https://gist.github.com/yarwelp/3cae5db566f643437fa2

HTH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.