I am trying to connect a Prolific pl2303 to my raspberry pi 4 running raspberry pi os 64 bit. When I look at dmesg I get the following output:

[ 31.714397] cam-dummy-reg: disabling
[ 44.046197] usb 1-1.1: USB disconnect, device number 3
[ 47.254348] usb 1-1.1: new full-speed USB device number 4 using xhci_hcd
[ 47.361386] usb 1-1.1: New USB device found, idVendor=067b,
idProduct=23a3, bcdDevice= 6.05
[ 47.361402] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 47.361407] usb 1-1.1: Product: USB-Serial Controller
[ 47.361412] usb 1-1.1: Manufacturer: Prolific Technology Inc.
[ 47.361417] usb 1-1.1: SerialNumber: ALBAb115819
[ 47.364081] pl2303 1-1.1:1.0: pl2303 converter detected
[ 47.364106] pl2303 1-1.1:1.0: unknown device type, please report to [email protected]

I have tried mailing that address and just got an error returned...

and with lsusb:

lsusb -v
Bus 001 Device 004: ID 067b:23a3 Prolific Technology, Inc. USB-Serial Controller
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0x067b Prolific Technology, Inc.
  idProduct          0x23a3
  bcdDevice            6.05
  iManufacturer           1 Prolific Technology Inc.
  iProduct                2 USB-Serial Controller
  iSerial                 3 ALBAb115819
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x0027
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      0
      bInterfaceProtocol      0
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x000a  1x 10 bytes
        bInterval               1
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0

Any help much appreciated. Thanks

  • I had a similar problem. So I went to Prolific Technology to download the most updated the driver. Problem solved.
    – tlfong01
    Jun 18, 2022 at 8:08
  • Do you have a link? I read that there was no need to download drivers as they are included in Linux. After a quick Google I've only found windows drivers.
    – Roaders
    Jun 18, 2022 at 13:24
  • Ref: raspberrypi.stackexchange.com/questions/96697/… I checked out more than 20 very old USB to TTL adaptors which have been collecting dust for over 10 years. I bought some of them for WinXP and found they no longer working for Win7. I also bought some for Win7, and found them no good for Win10. Just now I tried all these old guys for my Rpi3B+ Raspian 2019Apr to see if I had any luck. Surprisingly I found the following: Bad = 5 (not sure which driver) Good HL340 = 5 Good PL2302 = 7
    – tlfong01
    Jun 18, 2022 at 13:47

1 Answer 1


The answer to this seems to be that this usb device no longer works with raspberry pi os bullseye (kernel version 5.15.32-v8+). On buster (kernel version 5.10.103-v7+) it seems to still work fine. (get kernel version by running uname -r).

I found this on this mail thread: https://lore.kernel.org/linux-usb/YZytZ%[email protected]/T/

it seems like the kernel might be being fixed but I do not know what version of the kernel will contain the fix or how to update the kernel...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.