4

From the default NOOBS installation I have installed Raspbian. It seems NOOBS has added some settings to the config.txt file, where one of them is: hdmi_force_hotplug=1 which forces video to be on the HDMI port. Now imagine you have only an RCA cable (+an old tv), and a Windows computer, how do you remove that one line from the config.txt?

I've been wondering if there would be some key that you could hold down during the boot to override these settings, but I can't find anything like that?

Otherwise I have put the SD card in my Windows machine, and there I can find os/raspbian/boot.tar.xz which I can open with 7-Zip, and which contains a config.txt file. But that file does not seem to have the NOOBS added lines.

What is the easiest way around this? (I will need to explain it remotely to a beginner, once I find a way.)

5

I had the same problem. Everyone owns an HDMI TV except me (well, I do now). I found the following information only after a long long search. No one seems to be talking about it, so the wider community is not aware.

Display Mode Selection: By default, NOOBS will output over HDMI at your display's preferred resolution, even if no HDMI display is connected. If you do not see any output on your HDMI display or are using the composite output, press one of the following keys on your keyboard:

  • 1 to select HDMI preferred mode
  • 2 to select HDMI safe mode
  • 3 to select Composite PAL mode (for instance, Europe, China, India and Australia)
  • 4 to select Composite NTSC mode (for instance, North America, South Korea, and Taiwan)

Source: raspberrypi/noobs · GitHub

  • 1
    Yes I found that as well, but I guess it only works for NOOBS, and not anymore once you have used NOOBS to install Raspbian? – Niels Feb 22 '14 at 13:21
  • 1
    +1. Yes, this answer was the key information to get output on a TV with a SCART connector (pin 20 for the video signal (composite video in) and pin 18 for ground). It was a TV with PAL so pressing "3" started the video output. – Peter Mortensen Jun 5 '14 at 12:04
2

In my case, the SD card, when connected to the computer, had a noob.config file. I replaced

display_mode=0

(default to HDMI, I suppose) by

display_mode=3

and it worked fine.

1

Ive found the solution the hard way. In fact I haven't seen this anywhere in my frustrated research. The problem (?) is don't initiate Noobs or Raspberry Pi via a HDMI thinking then you can unplug it then go to the RCA output. Noobs really does save that initial connection. Be sure you've got the right setting on your CTR (Video source, or a channel that has received a rca input correctly) when you first connect.

0

You can view/edit the files in the FAT partition of the SD card on any computer, Mac, Linux or Windows. Specifically the settings in file config.txt. RPi-config / config.txt explains the settings.

For what it is worth, I think NOOBS creates more trouble than it is worth. It is OK if you want to explore the various OSes, but if you are going to use Raspbian you are better to just install this.

  • I've tried to find the config.txt, and all I can find is what I described above. I guess next time I'll install Raspbian directly. – Niels Feb 20 '14 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.