-1

I have a 170 degree fisheye USB camera module from ELP (camera model is ELP-USBFHD04H-L170). Yes, it's a configuration file I created using the command nano ~/.fswebcam.conf . I'm able to run the content of the file using the command fswebcam -c plugged into a USB port on my raspberry pi 3 model B. It is powered through the 5 volt connector to my laptop. It is capable of taking about 3-5 pictures before I get this message:

--- Opening /dev/video0...
Trying source module v4l2...
/dev/video0 opened.
Setting Brightness to 12 (59%).
Setting Contrast to 8 (12%).
--- Capturing frame...
Skipping 5 frames...
Timed out waiting for frame!
No frames captured.

I have gotten the camera to work again by turning of the pi and plugging the camera back in. Inevitably though, I get the timing out error again.

I created a configuration file using the command

nano ~/.fswebcam.conf

Additionally I run the program using the command

fswebcam -c ~/.fswebcam.conf

The contents of this file include:

device /dev/video0
input 0
loop 30
skip 20
#background
resolution 360x240
set brightness=60%
set contrast=13%
top-banner
font /usr/share/fonts/truetype/msttcorefonts/arial.ttf
title "Agmet Minirhizotron"
timestamp "%d-%m-%Y %H:%M:%S (%Z)"
jpeg 95
save /home/pi/camera/USB.jpg
palette MJPEG

How can I fix this??

New contributor
tentwentyone is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
6
  • What camera, what type of Raspberry Pi, what power supply, what software do you use? Where exactly do you get the error message?
    – Bodo
    Jun 23 at 16:41
  • I added this information to my original post. I'm very new to programming, so my apologies for not posting this before! Jun 23 at 17:00
  • I suggest to add the exact type/model of the camera. (Maybe something like USB30W02M-L170 ?) Do I understand right that the code below "My program" is the content of the configuration file webcam.cfg and that you somehow run fswebcam? (Show the command line you use.)
    – Bodo
    Jun 23 at 17:20
  • The camera model is ELP-USBFHD04H-L170. Yes, it's a configuration file I created using the command nano ~/.fswebcam.conf . I'm able to run the content of the file using the command fswebcam -c ~/.fswebcam.conf . Jun 23 at 17:25
  • Please edit your question to add requested information or clarification. It is best to copy and paste the command and its output to your question and format it as a code block. Unfortunately I don't know a solution, but adding details might help others to help you.
    – Bodo
    Jun 23 at 17:27

0

Your Answer

tentwentyone is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.