3

I'm running openelec+xbmc connected to my TV via HDMI cable, and my TV remote has stopped being able to control XBMC.

I'm not sure if it is the settings in xbmc/openelec that are incorrect, if there is something funny with the TV, or if it is the cable or the rpi itself.

I've power-cycled the TV and the rpi separately and together, and I can see that the remote is working OK because it controls the TV as usual. My TV is a panasonic TH-P42S10Z.

I have a possibly related issue of sound no longer working, when it previously did.

Does anyone have any ideas on how to tackle this?

  • I found that having a powered on Android TV connected regularised the Pi in such a way that ECE always works. YMMV – KayEss Sep 19 '14 at 6:03
1

I once found that connecting a second rpi to my tv stopped the remote from working on the first. Even after removing the rpi (but leaving the cable connected to the tv) this remained the same. I got the impression that there may be a sensing mechanism that was at work here. I'm not sure this will help you, but have you added a new hdmi device to your tv lately?

  • The rpi is the newest thing in the mix for me. – meataxe Feb 20 '14 at 8:31
  • 1
    I can confirm Jos' experience. I'm using a Philips TV. I 'removed' the pi from the devicelist in the televisions settings, and added it again, that worked. Later I had the idea that in these settings there was a possibility to set the CEC option (EasyLink for Philips, for Panasonic its VIERA Link or HDAVI Control or EZ-Sync) – ExploWare Mar 22 '14 at 7:55
  • The forum at raspberrypi.org reports of various forms of erratic behaviour for ECE with the Pi. Some suggest that a factory reset of the TV set helps fixing the issue. Other errors are traced back to the ESD protective circuit of the Pi (but those are only of relevance if the Pi is powered down). – Ghanima Sep 10 '14 at 13:24
1

There are three HDMI ports on this TV. The CEC is passed through port #1 only. Connecting the RPi to port #1 fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.