My machine will boot with this older Raspbian image, but I cannot update/upgrade the installation. I run:

sudo apt update

I get:

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Get:1 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:2 http://archive.raspberrypi.org/debian buster InRelease [32.6 kB]
Reading package lists...
E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'
E: Repository 'http://archive.raspberrypi.org/debian buster InRelease' changed its 'Suite' value from 'testing' to 'oldstable'

I spent time trying to decode this man page, but it is not my main goal in life to become an apt expert when I suspect that hardware/boot/EEPROM may be faulty.

Version 1 8GB RPI4  Model B (bootloader 6efe41bd 2022/01/25)
board: d03114 328abcf6 dc:a6:32:bb:3f:a6

The boot process DOES attempt to do NETBOOT if I don't have an SD card plugged in, but that is another whole magical mystery tour.

I can boot this old raspbian image, but nothing more modern. I cannot update the software on this machine due to the stable vs. oldstable and if I skip ahead to trying to install a newer 64-bit image of Raspberry PI OS or Ubuntu, I never progress past the "color wheel" and then there is no more signal on the HDMI port.

Other machines which show that they are Raspberry PI4 B version 1.4 have no difficulty booting the more modern OS images.

Any suggestions on how to move forward other than buying a newer Raspberry PI4 to match my other newer ones?

Per Millways suggestion, I have updated my question

Searching for EEPROM update yielded:

https://raspberryexpert.com/update-raspberry-pi/ titled How to Update Raspberry Pi (OS, Firmware, EEPROM & Kernel)

I ran:

sudo rpi-eeprom-update

and got the following output

BCM2711 detected
BOOTLOADER: up-to-date
CURRENT: Tue 25 Jan 2022 02:30:41 PM UTC (1643121041)
 LATEST: Tue 10 Sep 2019 10:41:50 AM UTC (1568112110)
VL805: up-to-date
CURRENT: 000138a1
LATEST: 000137ad

When I ran:

sudo rpi-eeprom-update -a

I got identical output and no update was performed.

Side note.. this did successfully update a different PI4 w/8GB.

I also took a flash drive out of another PI4 w/8GB RAM and tried on this machine and it failed to boot.

It showed the Color Wheel/Rainbow splash screen and then there was no power to the HDMI screen.

It appears up to date.

Per Joan's answer: I also prepared a fresh copy of Ubuntu 22.04 desktop using the RPI Flash tool. Same problem of color wheel and then no power to the HDMI port. RED LED is on and small green LED is slow flashing.

Later... Well now I seem to have "bricked" my PI4 with 8GB of RAM. I followed the directions in: [https://jamesachambers.com/raspberry-pi-4-bootloader-firmware-updating-recovery-guide/]

I followed the Recovery Procedure to make a bootload recovery MicroSD card. This part seemed to work, but now both Ubuntu 22.04 and Raspbian 2002-02-13 will fail to boot. I can't decode the blinking light pattern to decide what the underlying problem might be.

  • How are you attempting to update?
    – Milliways
    Jun 27, 2022 at 4:02
  • sudo apt update && sudo apt upgrade <--- That is what gave the message that the release was changed statsus from stable to "old stable"
    – sailnfool
    Jun 29, 2022 at 3:13
  • If you ACTUALLY used apt rather than apt-get it should prompt you to accept the suite change. This is normal as Bullseye is now the stable suite (and has been for more than 6 months).
    – Milliways
    Jun 29, 2022 at 6:07
  • I received no prompt. But now I am unable to try again after apparently hosing the eeprom and bricking my PI4.
    – sailnfool
    Jun 29, 2022 at 6:32

2 Answers 2


Firstly make sure the Pi's boot EEPROM software is up to date. You can search on-line for details. If you have problems with that stage provide details of the steps you took and the corresponding results.

Secondly prepare a fresh image using the Raspberry Pi imager software and flash to SD card.

If it fails to boot from this SD card provide details of LEDs etc.


It is unclear what you have done - following random instructions you find on the web is hazardous.

I suggest you follow the official documentation to Update the Bootloader

This should at least make the Pi bootable.

Whether your original OS is recoverable is unknown.

If it was me I would restore from a known good backup.

  • I apologize for not being clear. The directions I followed in James Chambers web page were indeed the same as the "Update the Bootloader" instructions for updating the Bootloader from the Raspberry PI official documentation. It is not true that I am totally bricked. The updated bootloader will launch, but when attempting to boot either Raspbian images that previously worked or Ubuntu or backups of other PI4 images (which boot on their respective machines), the boot process fails after the color wheel/rainbow.
    – sailnfool
    Jun 30, 2022 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.