0

I shut down my Raspberry Debian OS (properly using Shut Down) to attach a DHT22 Temperature and Humidity Sensor to the board.

After connecting the sensor, I started the Pi. I get a colorful splash screen at first. After a few seconds, the Welcome screen appears for a second, and that is the last I see. The power LED is working and red. But the green Act LED stops after a few blinks.

The SD card is completely new and is 16GB.

I reinstalled the OS on the SD card, to no avail. For the time being, I do not have another SD card to test whether that is the problem.

I also tried uncommenting the #hdmi_force_hotplug=1 in the config file.

I am just wondering what I have done wrong. Is it possible that such a normal temperature sensor damages the board or the SD card?

Raspberry Pi Model: Raspberry Pi 4 Model B 8GB

UPDATE 1:

I tried formatting the SD card and re-installing the Raspberry Pi OS. This is a recording of what happens when I start the Pi.

UPDATE 2:

I purchased another Micro SD card (32GB) and gave it another go. I got the same results plus one more error upon booting for the first time (something complaining about being Read-Only and failing to write wtmp).

Enabling ssh when writing the image did not make a difference either. This was suggested by one of the comments.

So, if it is the Pi board that is damaged due to connecting the sensor, how is one supposed to confirm that? There does not seem to be a lot to do if the SD card cannot boot the system.

And I don't think there are any compatibility issues because I was able to boot and do some work before connecting the sensor.

12
  • 1
    Perhaps you connected the sensor incorrectly and have damaged the Pi. No point in us wasting time in guessing. It is down to you to provide information if you want help.
    – joan
    Jun 27 at 21:04
  • disconnect the DHT22 sensor board
    – jsotola
    Jun 28 at 0:49
  • @jsotola I did it right after the first time the Pi didn't boot. Jun 28 at 5:57
  • @joan it could be. But without the SD card, I do get the Raspberry boot screen (the one that says there are no SD cards.) I just hope it is not the Pi that is damaged. Jun 28 at 6:20
  • 1
    enable ssh - and connect to the pi that way - it may be a display problem
    – Bravo
    Jun 28 at 12:26

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.