I have a raspberry pi 4 and using it for a while. I always connect it via SSH over local network with my computer.

But recently, I'm seeing and error such as: kex_exchange_identification: read: Connection timed out. I googled this and based on the recommendations I tried:

  • Replacing SD Card
  • Run the pi with other voltage source (Currently using official adapter.)
  • Different network, and different PC and
  • Different connection types like: SSH over powershell, Putty and VNC viewer.

Nothing changed. I can only connect 1/10th of it, and the connection drops shortly after connecting. Also tried with a monitor with hdmi cable, raspberry pi runs without a problem that time. So the only problem is with the SSH I suppose.

How can I solve this?


Update: After trying different networks, I started to believe that the problem is caused by the hotspot that I created. SSH connection has no problem over connecting the pi directly to the modem, but when I try to create a hotspot from the PC, and connecting the pi to that, I get that error.

However, problem still continues because It's the only form of connection I can use in what I do. I connected the pi to the modem for testing purposes.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.