0

I migrated my Raspberry Pi setup from 3 to 4 and now my TV is losing the minidlna connection after about 10 minutes every time. This results in a movie replay beeing stopped. I can then instantly find the Pi again on the TVs menu and browse the files to resume watching. Sometimes, I am even still in the menu.

I tried to find out the reason for this, setting up a second SD-card, mounting the USB share over CIFS additionally, changing the notify time of minidlna and installing a brand new config file by re-installing minidlna.

Nothing solved the problem.

I had the impression that reducing the notification time resulted in earlier disconnections.

When I use my old Pi 3 on parallel to mount the drive hosted by the new Pi 4 with CIFS it will play with no problems. Meaning I use the same source of files with another physical Pi.

The /var/log/minidlna/minidlna.log sais: upnphttp.c:922: error: DNS rebinding attack suspected. But this is not connected to the disconnections, meaning, the message does not coincide with a disconnection.

I also saw messages like upnp client disconnected but I can not find them any more.

I have nginx running, listening on some outside on ports but I can not relate them to the DNS rebinding attack stuff coming from minidlna.

Worth noting is maybe that I have several Pi's and I switched the SD-cards during the migration and I also setup some virtual lan hosts on the Pi with a script. I had the impression that this resulted in a virtual MAC address having the same IP as the physical MAC address on the other PI. I eventually reset everything and it works fine now but maybe the switches/router in my house did take some time to recognise this. I had troubles logging in via ssh because of that. But it is all soved and there are no virtual MACs currently and there have not been for several days now.

Does anybody have an ideas?

1 Answer 1

0

While writing this question I tried some last thing that came to mind:

I switched off the wifi port to make sure it has nothing to do with bad wifi (although I am connected to ethernet).

ifconfig wlan0 down

Seems that it solved the issue, altough I am not sure why.

Since this is just valid until shutdown I used crontab -e and appended the line

@reboot /usr/bin/sleep 60 && /usr/sbin/ifconfig wlan0 down

dmesg will show wlan0: link becomes ready at about 45 seconds after startup.

Will be shown by ip a.

I would appreciate if someone with at least 300 reputations could add the tag minidlna.


EDIT: There is also an option to configure on or interfaces to bind to with network_interface in /etc/minidlna.conf. I used this to bind to eth0 exclusively.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.