0

I am having problem while working with Raspberry Pi Model B 4GB.

When I turn on the power of Raspberry Pi the power LED (red in colour) turns on but the ACT LED (green/yellow in colour) just flashes two times and suddenly disappears and raspberry pi do not boots.

Please help me out!

2
  • Have you read the boot sticky forums.raspberrypi.com/viewtopic.php?t=58151#p1485558
    – CoderMike
    Jul 12 at 6:47
  • The ACT light will only be on continuously in a model 2 with no SD card in (or an SD card it cannot read). Otherwise it just blinks to indicate activity with the SD card, eg. at boot, usually quite vigorously for 5-20s, or, if there is some error with the content of the boot partition, it will blink endlessly in a regular pattern.
    – goldilocks
    Jul 12 at 14:36

1 Answer 1

1

The ACT (green) LED is configured in firmware to flash a "code" when there is a failure in boot process. The code has changed over time. I did a quick search for raspberry pi ACT LED codes. The first result seems current, but it indicates there is no code for 2 flashes.

You can also check the "Official-but-hard-to-use" documentation for boot diagnostics, and here again we find no description for 2 flashes.

As you've given us nothing else to go on, the following is offered purely as a GUESS:

  • Power supply < 5V
  • No SD card?
  • Improperly-formatted SD card

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.