I am trying to connect to internet using my Netgear WNA1100 dongle but when I connect my dongle my Ethernet goes off and the Raspberry Pi does not connect to the internet.

I have tried making both my wlan and eth0 IP address static but still I am not able to connect.

3 Answers 3


I had the same problem with a underpowered USB power supply. All the Pi software stuff worked fine, no SD corruption but when ever I plugged in a USB wifi adaptor everything went dead.

Try a powered USB hub plugged into the Pi and the wifi plugged into the hub, else get a new power supply.

  • Okay i'll try that... And post the results.. Feb 21, 2014 at 10:46

Try installing the wicd library and configure it using the application that appears in the menu when you launch the desktop (startx).

That's how I configured my netgear N300 wifi dongle.

Hope that will work for yours as well !


Wireless and LAN will not run at the same time. Once WAN connects, LAN drops out. There are ways to overcome this but really, you either use one or the other interface, since routing can be a problem, and requires additional configuration.

This answer talks about these problems

In terms of power, is the Pi still on after you plug in the USB Wireless? My Pi reboots some (most) times when I do this, but I have the very first editions. This got resolved with newer PCB.

Try and connect the Pi over HDMI and see what happens when you are directly connected to the Console. Does it reboot? Maybe it crashes? Thats the best way to debug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.