2

I have a Raspberry Pi 4B that only boots if an ethernet cable is plugged in. Basically on boot it waits for network boot until an ethernet cable is plugged in, then boots normally. How can I disable network boot or not require the ethernet cable be plugged in?

I've tried searching for it, but my google skill is failing me and I'm mostly seeing instructions about how to enable network boot.

The text on the boot screen is:

Boot mode: SD (01) order f4
Boot mode: SD (01) order f4
USB3[3]: 000002f1 connected
USB2[1]: 400202e1 connected
USB2 root HUB port 1 init
USB3[3] 00281203 connected enabled
USB3 root HUB port 3 init
MSD [02:00] 3.16 000000:03 register MSD
HUB [01:00] 2.16 000000:01 init port 3 speed 1
HID [03:01] 2.00 000003:01 register HID
xHC-CMD err: 13 type: 1 [03:01] 2.00 000003:01
HID error 1
NET_BOOT: e4:xx:xx:xx:xx:xx:xx wait for link TFTP: 0.0.0.0

/boot/cmdline.txt:

console=serial0,115200 console=tty1 root=PARTUUID=2e62ce1b-02 rootfstype=ext4 fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
  • Hardware is a Raspberry PI 4B with 8GB of RAM in an Argon ONE Case with a Kingston A400 SSD in the usb3 m.2 slot.
  • boot order is 0xf41
  • EEPROM is up to date
  • Running raspberry pi OS 2022.04.04
  • Canakit 3.5 Amp power supply.
4
  • AIUI, you've done something (made a change to your system) to enable it to boot from the network - is that correct? Have you tried to "undo" what you did?
    – Seamus
    Jul 30 at 20:39
  • Don't know what I did unfortunately haha Jul 31 at 1:30
  • OK - feedback on the answer (below) would be appreciated.
    – Seamus
    Jul 31 at 3:15
  • It's pretty weird, but looks like this is due to the something with the USB of the touchscreen I'm using. With the touchscreen USB unplugged it boots fine, with it connected it goes to network boot. I'll do some more digging. Jul 31 at 16:49

1 Answer 1

2

My guess is that you've either manually changed a configuration setting using raspi-config, or perhaps precipitated a configuration change by booting without an SD card.

In any event, with the information you've provided (not much), you might try this:

  1. make sure you've got a bootable SD card plugged into the card slot

  2. Boot your system - in whatever way you must

  3. Once you have access to the terminal, start raspi-config (`sudo raspi-config)

  4. Select the "Advanced Options" menu, then select the "Boot Order" option

  5. Select the option appropriate for you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.