0

I have a raspberry pi 3 with Debian os and I am unable to connect to it via ssh through VS code.The pi has already been configured and has a username and password.

The raspberry pi shows the message ‘couldn’t find an input interrupt endpoint’ before launching.

Here are the steps I follow:

  1. Enable SSH on the pi and find out its local IP address and connect the pi and the laptop on the same wifi.Delete the SSH folders at C:\Program Data\ and C:<user>\ username\

  2. Install remote SSH in vs code and add new host.

  3. It then asks for the ssh connection command and I enter ssh rpiusername@ipadrress.

  4. It then creates the .ssh file at C:\Users\username.ssh.

  5. The host gets added and then I chose linux as the platform for the remote host.

  6. It asks to continue and then asks for the password.

  7. I enter the password and it gets rejected 3 times.

  8. Finally it says it couldn’t establish connection and permission denied(Public key,password)

Here is what I get in the terminal

Log Level: 2


remote-ssh@0.85.2022071315

win32 x64

SSH Resolver called for "ssh-remote+192.168.0.171", attempt 1

"remote.SSH.useLocalServer": false

"remote.SSH.showLoginTerminal": false

"remote.SSH.remotePlatform": {}

"remote.SSH.path": undefined

"remote.SSH.configFile": C:\Users\username\.ssh

"remote.SSH.useFlock": true

"remote.SSH.lockfilesInTmp": false

"remote.SSH.localServerDownload": auto

"remote.SSH.remoteServerListenOnSocket": false

"remote.SSH.showLoginTerminal": false

"remote.SSH.defaultExtensions": []

"remote.SSH.loglevel": 2

"remote.SSH.enableDynamicForwarding": true

"remote.SSH.enableRemoteCommand": false

"remote.SSH.serverPickPortsFromRange": {}


"remote.SSH.serverInstallPath": {}

SSH Resolver called for host: 192.168.0.171

Setting up SSH remote "192.168.0.171"

Using commit id "3b889b090b5ad5793f524b5d1d39fda662b96a2a" and quality "stable" for server

Install and start server if needed

Checking ssh with "ssh -V"

> OpenSSH_for_Windows_8.1p1, 

> LibreSSL 3.0.2



Using SSH config file "C:\Users\username\.ssh"

Running script with connection command: ssh -T -D 51236 -F "C:\Users\username\.ssh" 
"192.168.0.171" bash

 Terminal shell path: C:\WINDOWS\System32\cmd.exe

> The authenticity of host '192.168.0.171 (192.168.0.171)' can't be established.

> ECDSA key fingerprint is SHA256:sJz0W0rNvgccVE9FCqqkRv4LoGOrlBUI8Y0p+8yznCs.

> Are you sure you want to continue connecting (yes/no/[fingerprint])? 
]0;C:\WINDOWS\System32\cmd.exe

Got some output, clearing connection timeout

Detected fingerprint confirmation message

Showing fingerprint confirmation dialog

Got fingerprint response: yes

"install" wrote data to terminal: "yes"

> y

> es

> Failed to add the host to the list of known hosts (C:\\Users\\username/.ssh/known_hosts).

> raspberrypi@192.168.0.171's password: 

Showing password prompt

Got password response

"install" wrote data to terminal: "**********"

 > 

 > Permission denied, please try again.

 > raspberrypi@192.168.0.171's password: 

 Showing password prompt

Got password response

"install" wrote data to terminal: "**********"

 > 

 > Permission denied, please try again.

 > raspberrypi@192.168.0.171's password: 

 Showing password prompt

 Got password response

"install" wrote data to terminal: "**********"

> 

> raspberrypi@192.168.0.171: Permission denied (publickey,password).

> The process tried to write to a nonexistent pipe.

"install" terminal command done

Install terminal quit with output: raspberrypi@192.168.0.171: Permission denied 
(publickey,password).

Received install output: raspberrypi@192.168.0.171: Permission denied (publickey,password).

Resolver error: Error: Permission denied (publickey,password).

    at Function.Create (c:\Users\username\.vscode\extensions\ms-vscode-remote.remote-ssh-
0.85.2022071315\out\extension.js:1:588535)

    at c:\Users\username\.vscode\extensions\ms-vscode-remote.remote-ssh-
0.85.2022071315\out\extension.js:1:586592

    at Object.t.handleInstallOutput (c:\Users\username\.vscode\extensions\ms-vscode-
remote.remote-ssh-0.85.2022071315\out\extension.js:1:587109)

    at Object.t.tryInstall (c:\Users\username\.vscode\extensions\ms-vscode-remote.remote-
ssh-0.85.2022071315\out\extension.js:1:684336)

    at processTicksAndRejections (node:internal/process/task_queues:96:5)

    at async c:\Users\username\.vscode\extensions\ms-vscode-remote.remote-ssh-
0.85.2022071315\out\extension.js:1:647221

    at async Object.t.withShowDetailsEvent (c:\Users\username\.vscode\extensions\ms-vscode-
remote.remote-ssh-0.85.2022071315\out\extension.js:1:650537)

    at async Object.t.resolve (c:\Users\username\.vscode\extensions\ms-vscode-remote.remote-
ssh-0.85.2022071315\out\extension.js:1:648271)

    at async c:\Users\username\.vscode\extensions\ms-vscode-remote.remote-ssh-
0.85.2022071315\out\extension.js:1:730993

I am 95% sure I am entering the correct password.I am unable to figure out the error so please help.

6
  • I am really sorry if i my question seems unreadable because I don't know how to format it. Jul 31 at 12:45
  • Formatting: for code / text block use curly brackets (e.g. after selecting the text to be formatted
    – Dirk
    Jul 31 at 13:09
  • Thanks,can you give me any idea on when will I get the answer to my query,its been an hour Jul 31 at 14:07
  • Are you ACTUALLY using Debian? If so try Raspberry Pi OS. Most of this seems to be about Windows so you are unlikely to get an answer here. Can you login to the Pi with keyboard? Have you tried a normal ssh client? Have you enabled ssh on the Pi - this is disabled by default.
    – Milliways
    Jul 31 at 23:17
  • You said that you downloaded ssh. Does that include sshd? Is sshd running on the pi?
    – NomadMaker
    Aug 1 at 0:09

1 Answer 1

0

It looks like the password is incorrect. Are you able to SSH into the Pi and use the same userid and password that you've configured VS Code to use?

Got password response
"install" wrote data to terminal: "**********"
 >
 > Permission denied, please try again
 > raspberrypi@192.168.0.171's password: 
 Showing password prompt
 Got password response
"install" wrote data to terminal: "**********"
> 
> raspberrypi@192.168.0.171: Permission denied (publickey,password).
3
  • The password is correct.Initially I had doubts,but then I had changed the password on the pi through raspi-config and its still not connecting to the pi. Jul 31 at 21:39
  • What is your Raspberry PI's userid? "pi" or "raspberrypi"? VS Code is using "raspberrypi". Aug 1 at 14:57
  • its raspberrypi Aug 1 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.