0

Hi guys I'm trying to access my raspberry pi through the remote desktop / vnc viewer without ethernet cable but only with wifi. And it connects only rarely and if it doesn't I get the error: Remote Desktop cannot connect to the remote computer for one of the following reasons

  1. Remote access to the server is not enabled
  2. The remote computer is turned off
  3. The remote computer is unavailable on the network

or sometimes "connection timed out"

I'd be really thankful for any help you can provide

8
  • 2
    Have you tried after booting without the ethernet cable? You need to provide far more information about how you have setup the network.
    – joan
    Aug 1 at 9:13
  • What do you mean by "remote desktop" ? How are you trying to connect?
    – Milliways
    Aug 1 at 9:48
  • Please edit your question and add more details. How exactly are you trying to connect in both cases? Copy&paste the error message to your question. In case you use an IP address: Your Raspberry Pi probably gets different IP addresses for ethernet and WiFi.
    – Bodo
    Aug 1 at 10:17
  • Have you disabled WiFi power management sudo iwconfig wlan0 power off?
    – Dougie
    Aug 1 at 16:19
  • 1
    You can enter that command on any valid terminal.
    – Dougie
    Aug 2 at 6:38

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.