0

I port forwarded my router to redirect traffic on ports 80 and 22 (ssh) to 192.168.1.123 I then set up no ip and set the update client to run on every boot. However, when I visit my no ip host name, I see my router's configuration page, as if I was typing in 192.168.1.1 from a local network. My router is a D link DSL-2640R.

This may not be the most appropriate site for this question

My pi definitely has a static internal ip.

  • Port forwarding doesn't really work when you are already behind the router. Try it from an external internet connection. – Gerben Feb 21 '14 at 14:49
1

This is not a Pi problem this is a router problem. If the connection is going to the router page and not the Pi, then Pi is not involved.

Factory reset is all else fails, I have had some very flaky routers in the past that worked until you tried to do anything out of the ordinary with them. Changed static ip address mapping, setting sometimes stuck sometimes did not sometimes worked sometimes did not.

  • My router is from TalkTalk and has non-standard firmware installed. I don't want to install default firmware because power cuts always happen when updating something – user60684 Feb 21 '14 at 8:42
1

You need to change the router admin interface port from 80 to something else. Given that your router is running a custom firmware specific to your ISP, that may not be possible.

The proper thing to do in that scenario would be to host your Raspberry Pi in a DMZ and configure the Pi's firewall to block incoming traffic from external IP addresses on all ports except 22 and 80.

  • Thanks, I can click on Advanced from the custom menu and get to the default firmware menu. – user60684 Feb 22 '14 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.