My Raspberry Pi 4b Ethernet Connection Reports 1000mbps, but All Browser's Website Speed Tests report 150mbps Download Speed.

I am not using WiFi. All internet connections are Cat6 direct ethernet.

I am not using SD cards, I am using USB 3.0 port Samsung 64 Gig Flash drives.

I tried both Raspbian and Windows 10 and both are about 8X too slow in the browser no matter what browser I use on either platform.

I tried to troubleshoot the problem in Raspbian with this command.

pi@raspberry:~ $ sudo ethtool eth0 | grep Speed

Speed: 1000Mb/s

As you can see the speed is reported at 1000mbps. The ethernet cable connector LEDs are solid orange and flashing green. Flashing green indicates a 1 gig connection.

I have no GPIO code running or any scripts just clean OS installs for Raspbian and Windows 10

I performed the following to update the OS

sudo rpi-eeprom-update -a (eeprom was one month out of date and now it's the newest)

sudo apt update

sudo apt full-upgrade

When I launch any browser and do a speed test using the sites listed below, all are about the same, incredibly slow!

I tried the following sites to test:




Is this normal? I can't even stream a YouTube video, it will buffer indefinitely. Web pages will load very slow and I can access some streaming live radio web pages without buffering.

  • The speedtest may be writing to the sd card - which is slow. forums.raspberrypi.com/viewtopic.php?t=261016
    – CoderMike
    Commented Aug 10, 2022 at 15:18
  • I am not using SD cards, I am using USB Samsung 64 Gig Flash drives Commented Aug 10, 2022 at 15:22
  • What is the write speed on your flash drive? What is your broadband speed?
    – CoderMike
    Commented Aug 10, 2022 at 15:27
  • I thought it was 400mb/s but after checking it is only 150mb/s. It looks like you hit the nail on the head. I just ordered 2 more flash disks from Amazon, they will be here by the weekend and I will see if that does the trick. I'm sure it will. I ordered 2 Samsung amazon.com/gp/product/B07BPKKTGL/… I can't find any faster unless I move to an M.2 or something Commented Aug 10, 2022 at 15:49
  • The speed limitation could very likely be your internet connection as well. So if you get a faster flash drive, that may bump you up in speed but an internet speed test won't go any faster than your connection pipe size. Do you have gigabit internet?
    – Jeff LaFay
    Commented Aug 10, 2022 at 15:57

2 Answers 2


Browser speed tests are not meaningful (unless you are testing your ISP) Use iperf3 to test interface performance.
See https://raspberrypi.stackexchange.com/a/138436/8697


You are troubleshooting two different issues.

The webpages loading slowly and YouTube videos buffering indefinitely can be a different issue from the Pi's ability to push data. (a myriad of other services can fail and deliver sluggish performance)

That being said, the theoretical limit of 1000mbps is not really realistic in real life. One way to test it, (apart from the iperf3 solution) is to connect both your PC and Pi to the same router via the 1 Gbps port and setup a decent sharing between the two.

Push a file from the router/NAS/PC to the PI over the 1 Gbps connection and check it's speed. For me, it's easily around the 500-700 Mbps with Raspbian running on a good SSD.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.