3

I followed this tutorial to set up a way to wirelessly backup my Mac to an external hard drive connected to the Raspberry Pi. All the steps went smoothly and I managed to mount and search the drive on Crashplan's GUI application on my Mac. However, when I try to select the files and directories I want to back up from my Mac, it only shows the file system of the Raspberry Pi, not my Mac's. Is there any way to fix this?

enter image description here

df -h

Filesystem      Size  Used Avail Use% Mounted on
rootfs          5.7G  2.2G  3.3G  40% /
/dev/root       5.7G  2.2G  3.3G  40% /
devtmpfs        211M     0  211M   0% /dev
tmpfs            44M  260K   44M   1% /run
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs            88M     0   88M   0% /run/shm
/dev/mmcblk0p5   60M   19M   41M  32% /boot
/dev/sda1       746G  290G  456G  39% /mnt/wd_element_1
/dev/sda2       187G  1.5G  185G   1% /mnt/wd_element_2

lsusb

Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 004: ID 1a40:0201 Terminus Technology Inc. FE 2.1 7-port Hub
Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 006: ID 1058:1048 Western Digital Technologies, Inc. 
  • Sounds like the external Hard drive isn't mounting within Raspbian...can you run df -h? – RPiAwesomeness Feb 21 '14 at 15:35
  • I believe it did successfully mount. Crashplan recognized that there is a previous Crashplan backup on my hard drive. – StarShire Feb 21 '14 at 15:38
  • Still doesn't hurt to check. What's the output of df -h and lsusb from the Pi? df -h checks for disk space, it's also an easy way to check for mounted drives. lsusb is LiSt USB, which will let us check for the hard drive (to see if it's actually seen by Raspbian - can't hurt) – RPiAwesomeness Feb 21 '14 at 15:43
  • Sure! I updated above. – StarShire Feb 21 '14 at 15:51
  • Hmmm...you're right, it is most definitely mounted and recognized. That is strange. I haven't actually used Crashplan so I'll have to look around. Have you tried googling this? – RPiAwesomeness Feb 21 '14 at 16:00
2

About a month ago, I successfully set up the same project - backing up a couple Macs using Crashplan on the Raspberry Pi. I have a guess at what your problem might be. I suspect it could be the last step of the page you linked, which links to Crashplan's instructions for a headless client here: http://support.code42.com/CrashPlan/Latest/Configuring/Configuring_A_Headless_Client

These instructions set up your Mac's Crashplan to configure Crashplan on the Raspberry Pi instead of your own Mac via ssh. My suspicion is that perhaps you missed the part at the bottom of that page to "Switch Your CrashPlan App Back." It involves reopening your ui.properties file and commenting out the servicePort=4200 line with a #.

Hope this is helpful.

  • I've tried commenting and uncommenting that line several times, but I mostly thought that you are supposed to have that line uncommented. But it's a good thing that it works now after few more tries. Thanks! By the way, is there any way to resume previous backup already on the drive instead of having to back up over the network from scratch? I've selected the correct backup directory on Crashplan (shows the correct size) but it keeps on deselecting itself. – StarShire Feb 27 '14 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.